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AWCC Installation Issues: Overheating, Keyboard Backlight, or User Interface Issues

Summary: The following article provides information about resolving various Alienware Command Center issues. These were tested on our G-Series laptops.

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Article Content


Symptoms


Experiencing various AWCC issues?

 

Have you encountered of the following Alienware Command Center (AWCC) issues?

  • The computer is overheating.
  • The Keyboard’s Backlight does not work.
  • The AWCC application cannot be launched.
  • Functions are missing from the AWCC Graphical User Interface (GUI). (For Example. Thermal control, Sound Center, FX…)

Check whether the audio driver, AWCC, or OCControls are installed or upgraded correctly. This can help to simplify the initial software troubleshooting.

If you do a clean install of the operating system and drivers on your computer? Or you upgrade the AWCC and the OCControls manually? You may encounter some trouble that is related to Thermal, Keyboard, or AWCC issues.

Note: The keyboard backlight can also be controlled using the Hotkeys and Function Shortcuts, but the color is only controllable by the AWCC application.


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Cause

 

Dell engineering has identified the Audio driver, AWCC, or OCControls not installing or upgrading correctly to be the main cause of these issues.

Issue Descriptions:

The Thermal icon is always shown as loading and never completes.

The OCControls being missing or not installing correctly can cause this.

Thermal Icon never loads

(Case.1 Thermal Icon never loads)

The Sounder Center icons are not shown on-screen.

The incorrect audio driver installed or AWCC not upgrading correctly can cause this.

You must have the correct Audio driver version for this version of AWCC. Generic Audio drivers can break the AWCC Sound Center features.

Sound Center Icons missing

(Case.2 Sound Center Icons Missing)

Some icons are missing, the FX tab does not work, the G key does not work, AWCC flash exit…so on.

Commonly caused by several root causes, but these can stop the AWCC application from fully installing.

FX Tab, G Key, does not function

(Case.3 FX tab, G Key, so on does not function)

Note: Check that your graphics drivers are up to date before carrying out the following installation instructions.
 


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Resolution

 

Recovery Solution:

Warning: Downloading and installing Dell-developed drivers or software from third-party or unknown sources can cause the computer or device not to work correctly. It can cause the computer to crash or not boot into the operating system. In some rare instances it can infect the computer with viruses, trojans, or other malicious software.
 
  1. Browse to https://www.dell.com/support/drivers.

  2. Identify your Dell computer.

    1. Click Download and Install SupportAssist to auto-detect your Dell computer. Follow the on-screen instructions to install Dell SupportAssist. For more information, see the Dell knowledge base article: Dell SupportAssist (formerly Dell System Detect): Overview and Common Questions

    2. Enter the Service Tag of the laptop and click Search.

    3. Or click Browse all products and select your Dell computer from the catalog.

  3. Under Category, select Applications.

  4. Locate the latest Alienware Command Center Application (Figure.1). (Version 5.2.91.0, A00 or newer.)

    AWCC

    (Figure.1 AWCC)

  5. Locate the latest Alienware OC Controls Application (Figure.2). (Version 1.3.0.1239, A00 or newer.)

    OCControls

    (Figure.2 OCControls)

  6. Click Download and save the files to a directory on your computer.

  7. Uninstall the current OCControls and then the Alienware Command Center Suite, and the audio driver (See Figure.3).

    Apps and Features

    (Figure.3 Apps & features)

  8. Open File Explorer and browse to the location where the downloaded files are saved.

  9. Double-click the AWCC installer and follow the on-screen instructions.

  10. Double-click the OC installer and follow the on-screen instructions.

  11. Reboot your computer again when they complete.

  12. Connect to your network.

  13. Launch the AWCC application from the start menu. (Wait for one to two minutes and do NOT close the application until the AWCC relaunch is completed.)

  1. Browse to https://www.dell.com/support/drivers.

  2. Identify your Dell computer.

    1. Click Download and Install SupportAssist to auto-detect your Dell computer. Follow the on-screen instructions to install Dell SupportAssist. For more information, see the Dell knowledge base article: Dell SupportAssist (formerly Dell System Detect): Overview and Common Questions

    2. Enter the Service Tag of the laptop and click Search.

    3. Or, click Browse all products and select your Dell computer from the catalog.

  3. Select the Operating System that is installed on the Dell computer.

  4. Under Category, select Audio.

  5. Locate the latest Realtek High Definition Audio Driver (Figure.4). (Version 6.0.8996.1, A02 or newer.)

    Audio Driver

    (Figure.4 Audio driver)

  6. Click Download and save the file to your computer.

  7. Under Category, select Applications.

  8. Locate the latest Alienware Command Center Application (Figure.5). (Version 5.2.91.0, A00 or newer.)

    AWCC

    (Figure.5 AWCC)

  9. Locate the latest Alienware OC Controls Application (Figure.6). (Version 1.3.0.1239, A00 or newer.)

    OCControls

    (Figure.6 OCControls)

  10. Click Download and save the files to a directory on your computer.

  11. Uninstall the current OCControls and then the Alienware Command Center Suite, and the audio driver (See Figure.7).

    Apps and Features

    (Figure.7 Apps & features)

  12. Open File Explorer and browse to the location where the downloaded files are saved.

  13. Double-click the Installer for the Audio driver.

  14. Reboot your computer when it completes.

  15. Double-click the AWCC installer and follow the on-screen instructions.

  16. Double-click the OC installer and follow the on-screen instructions.

  17. Reboot your computer again when they complete.

  18. Connect to your network.

  19. Launch the AWCC application from the start menu. (Wait for one to two minutes and do NOT close the application until the AWCC relaunch is completed.)

  1. Browse to https://www.dell.com/support/drivers.

  2. Identify your Dell computer.

    1. Click Download and Install SupportAssist to auto-detect your Dell computer. Follow the on-screen instructions to install Dell SupportAssist. For more information, see the Dell knowledge base article: Dell SupportAssist (formerly Dell System Detect): Overview and Common Questions

    2. Enter the Service Tag of the laptop and click Search.

    3. Or click Browse all products and select your Dell computer from the catalog.

  3. Select the Operating System that is installed on the Dell computer.

  4. Under Category, select Applications.

  5. Locate the latest Alienware Command Center Application (Figure.8). (Version 5.5.8.0 or newer includes a package manager installer.)

    AWCC

    (Figure.8 AWCC)

  6. Click Download and save the file to a directory on your computer.

  7. Uninstall the Alienware Command Center Suite.

  8. Open File Explorer and browse to the location where the downloaded files are saved.

  9. Double-click the AWCC installer and follow the on-screen instructions.

  10. Connect to your network.

  11. Launch the AWCC application from the start menu. (Wait for one to two minutes and do NOT close the application until the AWCC relaunch is completed.)


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Additional Information

Article Properties


Affected Product

Alienware m15 Ryzen Edition R5, Dell G3 15 3500, Dell G5 15 5500, Dell G5 SE 5505, Dell G15 5510, Dell G7 15 7500, Dell G7 17 7700

Last Published Date

20 Dec 2023

Version

11

Article Type

Solution