PowerProtect: Sikkerhetskopiering kan mislykkes med «Kan ikke sende forespørsel til utilgjengelig vert ved hjelp av adresse og port 7000»

Resumen: Denne artikkelen omhandler et problem med feil i sikkerhetskopiering i PowerProtect Data Manager 19.14 med klienter som bruker dobbel stabel.

Este artículo se aplica a Este artículo no se aplica a Este artículo no está vinculado a ningún producto específico. No se identifican todas las versiones del producto en este artículo.

Síntomas

Følgende feilmelding kan mottas når sikkerhetskopieringer mislykkes når klienter bruker dobbel stabel. Feilen vises i ADM-logger (/var/log/brs/adm/adm.log):

com.emc.dpsg.ecdm.adm.shared.exception.AdmException: Unable to send request to unreachable host 2196a9d9-3205-4507-81e0-d82d3a284f7a using address <ip_address> and port 7000

 

Følgende feil vises i AgentService-logger fra sikkerhetskopiklienten (DPSAPPS\AgentService\logs):

ERROR] C:\Program Files\DPSAPPS\AgentService\tmp_MEI1882\main.py-update_configs()-Line 249- error in updating configs: Error occurred while getting IP from FQDN: [Errno 11004] host not found.

 

MERK: Denne artikkelen gjelder bare for PowerProtect Data Manager 19.14. Denne artikkelen gjelder IKKE for noen versjoner før 19.14.

 

Causa

Det identifiseres et problem som kan oppstå i miljøer med dobbel stakk (IPv4 eller IPv6) der det ikke samsvarer mellom PowerProtect Data Manager, foretrukket IP-adresse for sikkerhetskopieringsklienten og agenttjenestens binding til IP-adressen for sikkerhetskopiklienten.

 

Resolución

Løsning:

  1. I programvertene kontrollerer du Agent Service-bindingsadressen ved hjelp av kommandoen nedenfor:

    • Linux eller AIX:
      netstat -an | grep <7000|port number>
    • Windows:
      netstat -an | findstr <7000|port number>
  2. PowerProtect Data Manager-serveren kontrollerer du oppløsningen for den foretrukne adressen ved å følge banen nedenfor:

    1. Gå til Application Agents-siden>, velg Host >More Actions>, Set Preferred Address. Registrer den foretrukne adressen.
    2. Bruk den foretrukne adressen fra trinn 2a og kjør kommandoen:
      curl -kv http://<preferred address>:<port number>/greetings

    Hvis det oppstår en feil, går du til trinn 3.

  3. Hvis det er en feil i trinn 2, kontrollerer du om det ikke er samsvar i adressen til IP-stakken fra trinn 1 og 2.

    1. Velg programverten fra brukergrensesnittet til PowerProtect Data Manager, og endre den foretrukne adressen slik at den samsvarer med IP-stakken i trinn 1.
      1. Gå til siden >Applikasjonsagenter, velg Flere verter-handlinger>>, angi foretrukket adresse, og endre den slik at den samsvarer med IP-stakken fra trinn 1.
        ELLER
    2. I Application Agent endrer du bindingsadressen til agenter slik at den samsvarer med den foretrukne adressen valgt av brukeren.
      1. Kjør installasjonsprogrammet og velg IP-adressen som ble funnet i trinn 2 som "Foretrukket programvertsadresse for kommunikasjon".

 

VIKTIG MERKNAD: Navneoppløsninger og omvendte oppslag konfigureres for å sikre følgende:
  • FQDN-ene til programagentverter som bruker FQDN som foretrukket vertsadresse, løses til en gyldig IPv4- eller IPv6-adresse.
  • Hver programagentvert som bruker FQDN som foretrukket vertsadresse, løser FQDN for PowerProtect Data Manager til en IP-adresse med samme protokoll som den bruker. Hvis en vert for eksempel bruker IPv4, løser den FQDN for PowerProtect Data Manager til en IPv4-adresse.

 

Productos afectados

PowerProtect Data Manager, PowerProtect Data Manager Essentials, PowerProtect Data Manager Software
Propiedades del artículo
Número del artículo: 000215647
Tipo de artículo: Solution
Última modificación: 15 abr 2024
Versión:  3
Encuentre respuestas a sus preguntas de otros usuarios de Dell
Servicios de soporte
Compruebe si el dispositivo está cubierto por los servicios de soporte.