NMCからのNVP-vProxyプラグインのインストールが失敗し、「vCenterプラグインのインストールに失敗しました」というメッセージが表示される

概要: NMCからのNVP-vProxyプラグインのインストールが失敗し、「vCenterプラグインのインストールに失敗しました」というメッセージが表示されます。

この記事は次に適用されます: この記事は次には適用されません: この記事は、特定の製品に関連付けられていません。 すべての製品パージョンがこの記事に記載されているわけではありません。

現象

NMCからのNVP-vProxyプラグインのインストールが失敗し、「vCenterプラグインのインストールに失敗しました」というメッセージが表示されます。

原因

NetWorker NVP-vProxy vCenterプラグインのインストールは、[保護]画面のNMCから[VMware View]を右クリックし、[vCenterプラグインのインストール

kA2f1000000Fw97CAC_1_0

]を選択することによって実行されます。これは、次のメッセージで失敗します。

kA2f1000000Fw97CAC_1_1

または、インストール メッセージが永久にスタックします:
image.png

NetWorker-vProxy: vCenter ServerからvProxyプラグインを削除する方法。

解決方法

これが失敗する理由を見つけるには、次の手順を使用して操作のデバッグ ログ ファイルを生成する必要があります。

1.NetWorker管理コンソール(NMC)クライアントで、Javaコンソールを有効にします。

NetWorker Runtime Environment (NRE)がインストールされている場合、Javaコントロール パネルには、NREのインストール場所(
C:\Program Files\NRE\java\jre<version>\bin\javacpl.exe
NREインストール パス
Oracle Java Runtime Environmentがインストールされている場合は、[ファイル名を指定して実行] [CTRL+R]を開き、「
javaws -viewer」と入力します
kA2f1000000Fw97CAC_3_0
Javaコントロール パネルから[詳細設定]タブに移動し、[コンソールの表示]をクリックします。
image.png

2.NMCを起動してログインします。
3.Javaコンソールで、「 5.
image.png

4.保護タブに移動して、vSphereプラグインのインストールを再試行します。
5.コンソールの[コピー]ボタンを使用してJavaデバッグ出力をメモ帳ファイルにコピーし、エラーを確認します

NetWorkerサーバーで、プラグインのインストール中に障害が発生していないかvcui.logを確認します。
Linux: /nsr/authc/logs/vcui.log
Windows: C:\Program Files\EMC NetWorker\nsr\authc-server\tomcat\logs\vcui.log
Scenario

ログでこれを見つけました:
network: プロキシ=DIRECT
networkを使用した https://nwserver1:9090/ebr-server/networker/session/connect」https://nwserver1:9090/ebr-server/networker/session/connect 接続: socket://nwserver1:9090 proxy=DIRECT
java.netUnknownHostException: nwserver1
at java.net.AbstractPlainSocketImpl.connect(Unknown Source)

NetWorkerサーバー ホスト(この場合はnwserver1)がNMCクライアントに認識されていなかったため、「UnknownHostException」が生成されています。  NetWorkerサーバーのIPアドレスとホスト名をNMCクライアントのホスト ファイルに追加することで、問題が解決しました。  NMCクライアントは、NMCサーバへのアクセスに使用しているブラウザのホストです。


NVP-vProxyプラグインをNMCからNetWorkerにインストールしようとすると、「vCenterプラグインのインストールに失敗しました」というメッセージが表示されて失敗します。


このビデオは YouTubeでも視聴できます。

対象製品

NetWorker

製品

NetWorker, NetWorker Series
文書のプロパティ
文書番号: 000036141
文書の種類: Solution
最終更新: 23 9月 2024
バージョン:  5
質問に対する他のDellユーザーからの回答を見つける
サポート サービス
お使いのデバイスがサポート サービスの対象かどうかを確認してください。