NetWorker RESTAPI: Beim Abfragen von JOBS wird "Code: 404, Meldung: Resource 'JOBID' is not found."

摘要: Sie versuchen, die NetWorker-Jobdatenbank (jobsdb) mit RESTAPI zu abfragen, und es wird Folgendes zurückgegeben: "message": "Resource '480702' is not found.", "Status": { "Code": 404, "codeClass": "Client-Fehler", "reasonPhrase": "Nicht gefunden" ...

本文适用于 本文不适用于 本文并非针对某种特定的产品。 本文并非包含所有产品版本。

症状

URLs wurden basierend auf der Ausgabe abgefragt, die vor dem Löschen der jobsdb erfasst wurde.
 
  • Sie versuchen, die NetWorker-Jobdatenbank (jobsdb) mit RESTAPI zu abfragen, und es wird Folgendes zurückgegeben:
https://NETWORKER_SERVER_NAME:9090/nwrestapi/v3/global/jobs/JOBID

{
    "message": "Resource '480702' is not found.",
    "status": {
        "code": 404,
        "codeClass": "Client Error",
        "reasonPhrase": "Not Found"
    },
    "timestamp": "YYYY-MM-SSTHH:mm:SS-TZ",
    "userAgentRequest": {
        "headers": [
            {
                "name": "Accept",
               "value": "*/*"
            },
            {
                "name": "Content-Type"
            }
        ],
        "method": "GET",
        "url": "https://lnx-client01.emclab.local:9090/nwrestapi/v3/global/jobs/480702"
    },
    "version": "x.x.x.x.Build.xxx"
}

原因

Standardmäßig behält der NetWorker-Server Jobinformationen 72 Stunden lang in der jobsdb bei. Der abgefragte Job wurde vor mehr als 72 Stunden abgeschlossen und die NetWorker -Policy "Server Protection" wurde ausgeführt. Das Server Protection "Server backup" enthält eine Ablaufaktion, mit der die Mediendatenbank aller abgelaufenen Savesets geleert und die jobsdb aller Jobs gelöscht wird, die älter als die jobsdb-Aufbewahrungsfrist sind.

解决方案

Erwartetes Verhalten, Jobs können nur abgefragt werden, wenn sie sich noch in jobsdb befinden. 

Rest API-Dokumentation ist verfügbar über: https://developer.dell.com/apis/2378/versions/v3/docs/GettingStarted.md

受影响的产品

NetWorker

产品

NetWorker
文章属性
文章编号: 000054099
文章类型: Solution
上次修改时间: 24 6月 2025
版本:  4
从其他戴尔用户那里查找问题的答案
支持服务
检查您的设备是否在支持服务涵盖的范围内。