NetWorker RESTAPI: L’interrogation des tâches renvoie le « code : 404, message : « JOBID » de la ressource est introuvable. »
摘要: Vous tentez d’interroger la base de données des tâches NetWorker (jobsdb) avec RESTAPI et renvoie les éléments suivants : "message": « Resource '480702' is not found. » « état » : { « code » : 404, « codeClass » : « Erreur client », « reasonPhrase » : « Introuvable » ...
本文适用于
本文不适用于
本文并非针对某种特定的产品。
本文并非包含所有产品版本。
症状
Les URL étaient interrogées en fonction de la sortie collectée avant le vidage de la jobsdb.
- Vous tentez d’interroger la base de données des tâches NetWorker (jobsdb) avec RESTAPI et renvoie les éléments suivants :
https://NETWORKER_SERVER_NAME:9090/nwrestapi/v3/global/jobs/JOBID
{
"message": "Resource '480702' is not found.",
"status": {
"code": 404,
"codeClass": "Client Error",
"reasonPhrase": "Not Found"
},
"timestamp": "YYYY-MM-SSTHH:mm:SS-TZ",
"userAgentRequest": {
"headers": [
{
"name": "Accept",
"value": "*/*"
},
{
"name": "Content-Type"
}
],
"method": "GET",
"url": "https://lnx-client01.emclab.local:9090/nwrestapi/v3/global/jobs/480702"
},
"version": "x.x.x.x.Build.xxx"
}
原因
Par défaut, le serveur NetWorker conserve les informations de tâche dans la base de données jobsdb pendant 72 heures. La tâche en cours d’interrogation s’est terminée il y a plus de 72 heures et la règle « Server Protection » de NetWorker s’est exécutée. Server Protection « Server backup » contient une action d’expiration qui vide la base de données des savesets expirés et efface également la jobsdb de toutes les tâches antérieures à la période de rétention jobsdb.
解决方案
Comportement attendu, les tâches peuvent être interrogées uniquement si elles se trouvent toujours dans la base de données jobsdb.
La documentation de l’API REST est disponible via : https://developer.dell.com/apis/2378/versions/v3/docs/GettingStarted.md
La documentation de l’API REST est disponible via : https://developer.dell.com/apis/2378/versions/v3/docs/GettingStarted.md
受影响的产品
NetWorker产品
NetWorker文章属性
文章编号: 000054099
文章类型: Solution
上次修改时间: 24 6月 2025
版本: 4
从其他戴尔用户那里查找问题的答案
支持服务
检查您的设备是否在支持服务涵盖的范围内。