NetWorker RESTAPI: Odpytując zadania zwraca kod": 404, komunikat: Nie znaleziono zasobu "JOBID".
摘要: Próbujesz zbadać bazę danych zadań NetWorker (jobsdb) przy użyciu RESTAPI i zwraca ona następujące elementy: "message": "Nie znaleziono zasobu "480702".", "status": { "kod": 404, "codeClass": "Błąd klienta", "reasonPhrase": "Nie znaleziono" ...
本文适用于
本文不适用于
本文并非针对某种特定的产品。
本文并非包含所有产品版本。
症状
Adresy URL były wypytywane w oparciu o dane wyjściowe zebrane przed opróżnianym dyskiem jobsdb.
- Próbujesz zbadać bazę danych zadań NetWorker (jobsdb) przy użyciu RESTAPI i zwraca ona następujące elementy:
https://NETWORKER_SERVER_NAME:9090/nwrestapi/v3/global/jobs/JOBID
{
"message": "Resource '480702' is not found.",
"status": {
"code": 404,
"codeClass": "Client Error",
"reasonPhrase": "Not Found"
},
"timestamp": "YYYY-MM-SSTHH:mm:SS-TZ",
"userAgentRequest": {
"headers": [
{
"name": "Accept",
"value": "*/*"
},
{
"name": "Content-Type"
}
],
"method": "GET",
"url": "https://lnx-client01.emclab.local:9090/nwrestapi/v3/global/jobs/480702"
},
"version": "x.x.x.x.Build.xxx"
}
原因
Domyślnie serwer NetWorker przechowuje informacje o zadaniach w katalogu jobsdb przez 72 godziny. Zadanie, które jest wykonywane w kwerendzie, zostało wykonane ponad 72 godziny temu i uruchomiono zasadę "Ochrona serwera" NetWorker. "Kopia zapasowa serwera" ochrony serwera zawiera czynność wygaśnięcia, która spowoduje opróżnienie bazy danych nośników wszystkich wygasłych zapisów, a także usunięcie katalogu jobsdb wszystkich zadań starszych niż okres przechowywania jobsdb.
解决方案
Oczekiwane zachowanie, zadania można wysyłać do kwerendy tylko wtedy, gdy nadal znajdują się w katalogu jobsdb.
Dokumentacja interfejsu REST API jest dostępna za pośrednictwem: https://developer.dell.com/apis/2378/versions/v3/docs/GettingStarted.md
Dokumentacja interfejsu REST API jest dostępna za pośrednictwem: https://developer.dell.com/apis/2378/versions/v3/docs/GettingStarted.md
受影响的产品
NetWorker产品
NetWorker文章属性
文章编号: 000054099
文章类型: Solution
上次修改时间: 24 6月 2025
版本: 4
从其他戴尔用户那里查找问题的答案
支持服务
检查您的设备是否在支持服务涵盖的范围内。