|

Upgrade your browser for more secure shopping


Your security is our top priority. That's why we have taken precautionary measures to provide our customers with a safe and enjoyable shopping experience. Support for older browsers will end on June 30th, 2018. Determine your browser version and upgrade to the latest version or a new supported browser from the list below.

Supported browsers

Premier will no longer support browsers that do not use the Transport Layer Security (TLS) 1.2 security protocol. Browsers that do use TLS 1.2 offer the safest way for you to shop online. We support the latest versions of most major browsers that use TLS 1.2 security, including:

Frequently asked questions

I've downloaded a new browser version. Why do I still see a browser upgrade alert?
To use this website, you must enable cookies, JavaScript and TLS 1.2 in your browser settings. These settings can be found in your browser options menu.

Dell recommends that you install the latest browser version available and keep your computer's operating system up-to-date with the latest security patches.

I use my work computer to shop on Premier and I can't upgrade my browser.
Contact your internal team administrator and let them know you want to upgrade your browser to one of the supported browsers in the list above.

Why won't Premier work using IE 8, 9 or 10?
Internet Explorer (below 11) does not support TLS 1.2 by default, which is required to connect and shop with your Premier account. If you are using IE 11, please check your browser settings to confirm that TLS 1.2 is enabled and that you have Compatibility View turned off. If you are using IE 10 or below, you must download a supported browser from the list above.

If you are using IE 11, please check your browser settings to confirm that TLS 1.2 is enabled and that you have Compatibility View turned off.

If you have verified those settings are correct and you are still seeing a TLS related message in IE11, please contact your Premier Representative.