NetWorker: Windows Client Failing With "The process cannot access the file because it is being used by another process (Win32 error 0x20))"

Summary: Windows Client Failing With "The process cannot access the file because it is being used by another process (Win32 error 0x20))"

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Windows client is failing to backup certain save sets, and the following error is being displayed: "The process cannot access the file because it is being used by another process (Win32 error 0x20)"

Cause

This is not a NetWorker error, this is indicated by the Windows OS error code: (Win32 error 0x20)

0x00000020

ERROR_SHARING_VIOLATION

The process cannot access the file because it is being used by another process.


See the following Microsoft Document: Win32 Error Codes This hyperlink is taking you to a website outside of Dell Technologies.

Resolution

This should not occur on clients where Volume Shadowcopy Service (VSS) is enabled. To check if VSS is enabled, open the client properties from the NetWorker Management Console (NMC). Under Protection->Clients, in the client properties the Apps & Modules tab, ensure that the "Save Operations" field does not contain VSS:*=OFF
Save operation to disable VSS 
If this option is set, remove it.

Additional Information

On most standard Windows File System clients VSS should not be disabled. This should only be done for troubleshooting purposes to identify Windows VSS as another failure cause. Persistent VSS failures require Microsoft support engagement for root cause and solution.

If enabling VSS does not resolve the issue, or you do not want to enable VSS you have two other options:

  1. Try to schedule this clients backup during a period when access activity on it is reduced.
  2. Use NetWorker directives to skip these files, so the backup does not indicate a failure; however, this means that the data is not backed up. This resolution depends on the importance of the directories/files which are failing with this message. Typically this error occurs on .log and .dat files. The NetWorker Command Reference Guide provides information about directives. Support for NetWorker | Manuals & Documents 


For more information about VSS and its uses, review the following: Volume Shadow Copy Service This hyperlink is taking you to a website outside of Dell Technologies.

NetWorker: Troubleshooting Backup Failures Due to VSS Issues

Affected Products

NetWorker

Products

NetWorker
Article Properties
Article Number: 000031490
Article Type: Solution
Last Modified: 24 Oct 2025
Version:  6
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