ChromeOS Post Boot Diagnostics
Summary: General information about the ChromeOS diagnostics tool.
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Cause
No cause information is available.
Resolution
Table of Contents:
Overview
The new ChromeOS diagnostics tool can be used to investigate the battery, processor, and memory status of a Chromebook in real time.
You can run troubleshooting test routines, where results and telemetric information can be saved in a session log file. This can be used to assist with the following:
- Streamline the troubleshooting process.
- Easier knowledge transfer and sharing of results
- Enable Support Agents to identify the best cost-effective fix and to validate a solution.
When should the Diagnostics tool be used?
- The Chromebook battery is draining fast.
- The Chromebook is running slow.
- The Chromebook is having memory problems.
How to Access the Diagnostics Tool.
You can use the following two methods to access the diagnostics tool.
With the Launcher
- At the bottom left of the screen, select the Launcher.

- Locate the Omnibox.

- Type Diagnostics in the Omnibox to locate the tool.

With the Settings
- At the bottom right of the screen, select the Status Tray.

- Select Settings.

- Select Search (magnifying glass).

- Type Diagnostics into the Settings search bar. Select Diagnostics in the search results (or press the Enter button).

- Under About ChromeOS, locate and select Diagnostics to open the App.

- Select the diagnostic you would like to run.

Note: Running the processor tests can stress the Chromebook to the point where normal use may be difficult. Typical run times for tests are:
- Battery 10-15 minutes
- Processor 10-15 minutes
- Memory 10-40 minutes
Running the Diagnostics and Test Results.
Use the following steps to run the diagnostics and save the test results.
Note: Only one test can be run at a time. The steps below are for the battery test, but is used as an example.
- Select Run Charge Test.
Assess the discharge rate.
*The Chromebook should be unplugged from AC power for the battery test.
- If a test fails in any of the three testing routines, you may investigate more from the Help Center
.

- A faster way to investigate why certain tests have failed is clicking "Why has this test failed?"

- If a test fails, session logs are saved by clicking Save session log (at the bottom of the Diagnostics tool).

- You can download the .txt file and share it using chat support, email, or verbally on the phone.

Diagnostic logs are only available on ChromeOS devices running version 90 and above. Learn More About Updating a Chromebook's Operating System.
Affected Products
Chromebook, Chromebook, ChromebookArticle Properties
Article Number: 000186767
Article Type: Solution
Last Modified: 24 Oct 2025
Version: 3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.