NetWorker: Upgrade Fails with "Unable to connect server, Remote system error…"

Summary: Unable to connect server, Remote system error, No connection could be made because the target machine actively refused it.

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Symptoms

Upgrade to NetWorker 9.1 in order to use vSphere 6.5.

 

The following error message in NMC:

Unable to connect server, Remote system error, No connection could be made because the target machine actively refused it


nsrctld NSR notice Daemon nsrd terminated


C:\Program Files\EMC NetWorker\nsr\logs>nsrrpcinfo -t <Networker_server_name> 390103
nsrrpcinfo: Remote system error - Only one usage of each socket address (protocol/network address/port) is normally permitted.


nsrjobd severe Unable to query RAP database for initial RDZ value: RPC send operation failed; peer = ::1:[8992], errno = An existing connection was forcibly closed by the remote host.

 

Cause

The process nsrd keeps failing, and restarting.
NSRDB is corrupted.

 

Resolution

Steps:

  1. Follow the procedure to recover nsrdb, using nsrdr.
    Open a command prompt as user administrator or root and run:
    mminfo -B

  2. If MM is unavailable, log in to \nsr\logs\policy\Server Protection\Server backup, search for the latest bootstrap backup, and take notes of the highlighted information.
    Example:

129292:save: Successfully established Client direct save session for save-set ID '2025432100' (networker.com:bootstrap) with Data Domain volume 'POOLFILESERVER.001'.
Picked up JAVA_TOOL_OPTIONS: -Djava.vendor="New Oracle"
save: bootstrap                   level=full,     36 MB 00:00:23    412 files
completed savetime=1488561188
7167:save: save completion time: 3/3/2017 11:13:31 AM
94694:save: The backup of save set 'bootstrap' succeeded
Bootstrap saveset: 2025432100
Volume:POOLFILESERVER.001

 

  1. Inside nsr\logs\policy\Server Protection\Server backup, you may also find a file with the information about Pool or Volume. For example

3/3/2017 11:13:08 AM  2025432100  POOLFILESERVER.001 datadomain datadomain_FILESERVER datadomain:/ddnw/FILESERVER

 

  1. Stop all NetWorker services.

    Rename res folder under <NetWorker Installation path>\nsr

  2. Start NetWorker services.

  3. Open NMC, reconfigure the device where the Saveset was saved.

  4. From a command prompt as user administrator or root run the command:

nsrdr -B {bootstrap_saveset_id} -d {device}

 

  1. To open nsrdr in interactive mode. For example
    nsrdr -B 2025432100 -d ddnw

  1. After completion restart all NetWorker services.

 

Open NMC if its empty or present an error message:

An error occurred while validating user credentials. Verify that NetWorker Authentication Service is running.

 

  1. Stop GST services.

  2. Reauthorize the NMC with NWS.

gstauthcfg -ct -h New_authentication_service_hostname -p port_number
nsrauthtrust -H Authentication_service_host -P Authentication_service_port_number
nsraddadmin -H Authentication_service_host -P Authentication_service_port_number

 

Additional Information

Affected Products

NetWorker
Article Properties
Article Number: 000063048
Article Type: Solution
Last Modified: 25 Mar 2025
Version:  6
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