IDPA: ACM-grensesnittet viser feilen "Backup Server viewuser user password is out of sync. Oppdater det nyeste passordet» på instrumentpanelet for sikkerhetskopieringsserveren
Summary: Denne artikkelen dekker problemet der brukerpassordet for Visningsprogram på Avamar/Backup Server er uendret, men ACM-brukergrensesnittet viser feilen «Brukerpassordet for sikkerhetskopieringsservervisning er usynkronisert). Oppdater det nyeste passordet på instrumentpanelet for sikkerhetskopieringsserveren. Dette problemet kan oppstå hvis et verktøy er i ferd med å oppgradere kode. ...
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
ACM-grensesnittet viser feilen "Backup Server viewuser user password is out of sync. Oppdater det nyeste passordet på instrumentpanelet for sikkerhetskopieringsserveren.
Når brukeren klikker på popup-vinduet password out of sync og prøver å oppdatere passordet, viser brukergrensesnittet feilen «Avamar viewuser user test connection failed»:
Open SSH to ACM as 'root' user and run the following command to confirm if this issue is caused due to MCSDK compatibility where ACM is unable to login to Avamar or Backup Server Postgres Database using MCSDK:
Eksempel:
Kommandoen ovenfor peker på et kompatibilitetsproblem mellom ACM og Avamar/Backup Server MCSDK fordi ACM ikke er i stand til å hente visningspassordstatus ved å logge på Postgres-databasen på Avamar-serveren.
Åpne SSH til Avamar eller Backup Server, og kontroller om visningspassordet fungerer på manuelt påloggingsforsøk.
Når vi har identifisert riktig passord, klikker du på passordet for brukerpassordet som ikke er synkronisert, og prøver å oppdatere dette passordet. Hvis vi ser testtilkoblingsfeil, går du videre til løsningsdelen.
Når brukeren klikker på popup-vinduet password out of sync og prøver å oppdatere passordet, viser brukergrensesnittet feilen «Avamar viewuser user test connection failed»:
Open SSH to ACM as 'root' user and run the following command to confirm if this issue is caused due to MCSDK compatibility where ACM is unable to login to Avamar or Backup Server Postgres Database using MCSDK:
grep -i "SQLException.*viewuser.*authentication.*not supported" -A2 /usr/local/dataprotection/var/configmgr/server_data/logs/server.log
Eksempel:
2021-03-30 10:45:25,304 INFO [https-jsse-nio-8543-exec-10]-restadapter.LoginService: Test connection failed for Avamar server viewuser 2021-03-30 10:49:08,451 ERROR [Thread-379779]-avadapter.AvamarUtil: SQLException while checking viewuser connection: org.postgresql.util.PSQLException: The authentication type 10 is not supported. Check that you have configured the pg_hba.conf file to include the client's IP address or subnet, and that it is using an authentication scheme supported by the driver. 2021-03-30 10:57:57,402 ERROR [https-jsse-nio-8543-exec-10]-avadapter.AvamarUtil: SQLException while checking viewuser connection: org.postgresql.util.PSQLException: The authentication type 10 is not supported. Check that you have configured the pg_hba.conf file to include the client's IP address or subnet, and that it is using an authentication scheme supported by the driver.
Kommandoen ovenfor peker på et kompatibilitetsproblem mellom ACM og Avamar/Backup Server MCSDK fordi ACM ikke er i stand til å hente visningspassordstatus ved å logge på Postgres-databasen på Avamar-serveren.
Åpne SSH til Avamar eller Backup Server, og kontroller om visningspassordet fungerer på manuelt påloggingsforsøk.
- Kontroller at visningsbrukerens pålogging fungerer ved hjelp av følgende kommando:
-
psql -p 5555 mcdb -U viewuser -h
-
Når vi har identifisert riktig passord, klikker du på passordet for brukerpassordet som ikke er synkronisert, og prøver å oppdatere dette passordet. Hvis vi ser testtilkoblingsfeil, går du videre til løsningsdelen.
Cause
Kompatibilitetsproblem mellom ACM og Avamar eller sikkerhetskopieringsserver. Dette problemet kan oppstå hvis Avamar har blitt oppgradert til høyere versjon, men ACM er ennå ikke oppgradert. For eksempel når det gjelder IDPA DP8X-modeller, er Avamar ikke en del av arbeidsflyten for IDPA-oppgradering og oppgraderes som en del av en egen arbeidsflyt.
Anbefaling for IDPA DP8X-oppgraderinger:
Anbefaling for IDPA DP8X-oppgraderinger:
- Arbeidsflyten for IDPA-oppgradering fra ACM må startes først.
- Når arbeidsflyten for IDPA-oppgradering når ESXi-oppgraderingsfasen, kan Avamar-oppgradering deretter startes for å unngå slike kompatibilitetsproblemer.
Resolution
1. Åpne SSH til Avamar Server/ Backup Server som "admin user and verify the following details:
2. Åpne SSH til ACM som rotbruker, og kontroller IDPA-versjonen:
3. Kontroller at ACM-versjonen samsvarer med den respektive Avamar-versjonen i henhold til leverandøren av stabeltabellen nedenfor:
Merk: Hvis ACM- og Avamar-versjonene som er angitt i trinn 1 og 2, ikke samsvarer med tabellen ovenfor, vil dette forklare kompatibilitetsproblemet.
4. Oppgrader resten av IDPA- eller Avamar-versjonene slik at de samsvarer med IDPA Stack-versjonene. Hvis dette er et DP8X-verktøy midt i en oppgradering, forventes denne feilen og venter til oppgraderingsprosessen fullføres fullstendig.
mcserver.sh --version
2. Åpne SSH til ACM som rotbruker, og kontroller IDPA-versjonen:
rpm -qa | grep -i dataprotection
3. Kontroller at ACM-versjonen samsvarer med den respektive Avamar-versjonen i henhold til leverandøren av stabeltabellen nedenfor:
| IDPA-versjon (ACM-versjon) | Avamar- eller sikkerhetskopieringsserverversjon |
| 2.2 | 7.5.1.101 |
| 2.3.x | 18.2.0.134 |
| 2.4.x | 18.2.0.134 |
| 2,5 | 19.1.0.38 |
| 2.6.x | 19.3.0.149 |
Merk: Hvis ACM- og Avamar-versjonene som er angitt i trinn 1 og 2, ikke samsvarer med tabellen ovenfor, vil dette forklare kompatibilitetsproblemet.
4. Oppgrader resten av IDPA- eller Avamar-versjonene slik at de samsvarer med IDPA Stack-versjonene. Hvis dette er et DP8X-verktøy midt i en oppgradering, forventes denne feilen og venter til oppgraderingsprosessen fullføres fullstendig.
Affected Products
Integrated Data Protection Appliance FamilyProducts
PowerProtect DP8300, PowerProtect DP8800, PowerProtect Data Protection Software, PowerProtect Data Protection Hardware, PowerProtect DP8400, PowerProtect DP8900Article Properties
Article Number: 000185598
Article Type: Solution
Last Modified: 01 Sept 2023
Version: 4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.