PowerProtect Data Manager 19.12 and earlier: High CPU usage by the Agent Service

Summary: High Central Processing Unit (CPU) usage by the Agent Service’s operating system (OS) process.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

A host's operating system shows high CPU usage when running PowerProtect Data Manager 19.12 or earlier versions.

There are no symptoms visible in the logs, but the behavior occurs in the host's Task Manager application.

Cause

There are two known causes for spiking CPU behavior:

  1. The tasks.db file must reload for each iteration. If it is large, each time this happens, it causes a spike in CPU consumption.
  2. Version 19.11 uses a lockbox Application Programming Interface (API) call for every GET session API call.

This lockbox API call consumes more CPU than normal. The polling for a GET session API runs every 30 s.
There is an unnecessary call in this request that tries to decrypt the password each time.  

Resolution

Affected versions: This issue impacts v19.12 and earlier versions.

Workaround: 

  1. Stop the Agent Service.
  2. Rename the tasks.db in C:\Program Files\DPSAPPS\AgentService\dbs\v1.
  3. Restart the Agent Service.

Fixed version: The issue is not present in v19.13 and later versions.

 

Affected Products

PowerProtect Data Manager, PowerProtect Software
Article Properties
Article Number: 000212583
Article Type: Solution
Last Modified: 06 Oct 2025
Version:  3
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