High CPU usage is observed post upgrading to SupportAssist for Home PCs v4.6.2

Summary: Experiencing high CPU usage after upgrading to SupportAssist for Home PCs v4.6.2? Follow the steps below to optimize performance.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Affected Products:

  • SupportAssist for Home PCs v4.6.2

High CPU or memory usage has been noticed, after upgrading to SupportAssist for Home PCs v4.6.2.

High memory usage in Windows Task Manager

Cause

Users may experience high CPU usage due to Dell Data Manager and Dell Instrumentation running on the computer, which can lead to the following symptoms:

  • Slow Performance
  • The computer stops responding
  • Overall performance degradation

Resolution

The issue has been resolved with latest SupportAssist v4.6.3. Update to the latest version of SupportAssist for Home PCs (Released on December 23, 2024).

Affected Products

SupportAssist for Home PCs
Article Properties
Article Number: 000263857
Article Type: Solution
Last Modified: 16 Sept 2025
Version:  5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.