Avamar: Scheduled backups do not start while manually initiated backups work

Summary: This article addresses a rare issue where scheduled backups do not start, while manually initiated backups work without issue, due to a misconfigured hosts file.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Scheduled backups do not run.

The backup scheduler is running:

dpnctl status sched
Identity added: /home/admin/.ssh/admin_key (/home/admin/.ssh/admin_key)
dpnctl: INFO: Backup scheduler status: up. 
 

Manually initiated backups complete successfully.

The log (/usr/local/avamar/var/mc/server_log/mcserver.log*) shows the following:

07/30-22:25:31.00645 [OtherMessageEventHandler#235] com.avamar.mc.security.AvmgrLoginModule.login
FINE: AvmgrLoginModule Product: MCS Remote client: customer.com.mx/127.0.0.1 Host address: /IPv6 address b%eth0 Host address: /10.xx.xx.11
07/30-22:25:31.00645 [OtherMessageEventHandler#235] com.avamar.mc.security.spring.MCSpringJaasSecurityModule.authenticateLoginPrincipal
SEVERE: Authentication failed: Login Failure: all modules ignored
org.springframework.security.authentication.AuthenticationServiceException: Login Failure: all modules ignored
        at org.springframework.security.authentication.jaas.DefaultLoginExceptionResolver.resolveException(DefaultLoginExceptionResolver.java:33)
  ...
          at java.lang.Thread.run(Unknown Source)
Caused by: javax.security.auth.login.LoginException: Login Failure: all modules ignored
        at javax.security.auth.login.LoginContext.invoke(Unknown Source)
        at javax.security.auth.login.LoginContext.access$000(Unknown Source)
  ...
 

A ping test to the Fully Qualified Domain Name (FQDN) customer.com.mx received a reply from the localhost address 127.0.0.1.

Cause

The localhost entry in the /etc/hosts file was not configured correctly.

 

Resolution

1. Log in as admin.

2. Elevate to root privilege.

3. Review the hosts file:

cat /etc/hosts
127.0.0.1     customer.com.mx localhost
::1           customer.com.mx localhost
10.xx.xx.11   cusotmer.com.mx customer
 

This output shows an incorrectly configured hosts file.

The correct configuration for localhost in /etc/hosts is:

127.0.0.1       localhost
::1             localhost
 

4. Update, and correct the hosts file.

5. Review the updated hosts file:

cat /etc/hosts
127.0.0.1     localhost
::1           localhost
10.xx.xx.11   cusotmer.com.mx customer
 

6. Restart the Management Console Server (MCS) per Avamar: How to Restart Management Console Server

7. Monitor the grid and verify that scheduled backups run.

Affected Products

Avamar Server

Products

Avamar, Avamar Data Store, Avamar Server, Avamar Virtual Edition
Article Properties
Article Number: 000048620
Article Type: Solution
Last Modified: 02 Sept 2025
Version:  3
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