Isilon: Cannot Find Disk Provider Error On Reimaging

Summary: Cannot find disk provider error can occur when the reimage program cannot find a bootstrap provider.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

The error message "Cannot find disk provider" appears during the reimaging process.

Cannot find disk provider
Traceback (most recent call last):
  File "/root/bin/flashdisk_reimage.py", line 2375, in 
    sys.exit(main(getargs()))
  File "/root/bin/flashdisk_reimage.py", line 2251, in main
    setup_psi(args)
  File "/root/bin/flashdisk_reimage.py", line 1703, in setup_psi
    setup_psi_backup_device(args)
  File "/root/bin/flashdisk_reimage.py", line 1763, in setup_psi_backup_device
    psi_backup_device.providers.init_short()
  File "/root/bin/flashdisk_reimage.py", line 1213, in init_short
    bootdisk.init_providers(wipe=False)
  File "/b/mnt/obj/b/mnt/src/amd64.amd64/isilon/lib/python/stage-3.8/usr/local/lib/python3.8/site-packages/isi/sys/bootdisk.py", line 729, in init_providers
  File "/b/mnt/obj/b/mnt/src/amd64.amd64/isilon/lib/python/stage-3.8/usr/local/lib/python3.8/site-packages/isi/sys/bootdisk.py", line 730, in 
IndexError: list index out of range

The command to confirm the issue is: isi_bootstrap_devices -b, which produces the following output:

isi-bsd# /usr/bin/isi_hwtools/isi_bootstrap_devices -b
name:
isi-bsd#

Cause

The cause of this issue is a disk missing in the highest slot number of the A sled for the node.

Resolution

To resolve the issue, follow these steps:

  • Put a drive into the highest slot number of the A sled for the node. If the drive was removed due to a fault, replace the faulted drive before continuing.
  • If you have a drive in the highest A slot number, swap the drive with another drive in the sled. Once the sled is reseated, attempt the reimage process again.

 

Caution: If you are unsure or concerned about making these changes, contact Dell Support or browse their website for further assistance.
Note: Handle the hardware with care to avoid any damage.

Affected Products

Isilon Gen6, PowerScale A310, PowerScale A3100, PowerScale H710, PowerScale H7100
Article Properties
Article Number: 000359362
Article Type: Solution
Last Modified: 17 Oct 2025
Version:  1
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