NetWorker: Index of the NetWorker server fails to be backed-up onto a remote storage node
Summary: NetWorker bootstrap and index backups configured through a remote storage node device fail
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
NetWorker server bootstrap and index save set fail with the following error:
181407:save: Step (1 of 7) for PID-18603: Save has been started on the client 'Server_Name'. 174412:save: Step (2 of 7) for PID-18603: Running the backup on the client 'Server_Name' for the save set 'index:c42c8a26-00000004-5bf6bdfd-5bf6bdfc-00015000-da5bbc56'. 107204:save: 'Backup renamed directories' disabled, renamed directories will not be backed up 180569:save: Identified a save for the backup with PID-18603 on the client 'Server_Name'. Updating the total number of steps from 7 to 6. 174920:save: Step (3 of 6) for PID-18603: Contacting the NetWorker server through the nsrd process to obtain a handle to the target media device through the nsrmmd process for the save set 'index:c42c8a26-00000004-5bf6bdfd-5bf6bdfc-00015000-da5bbc56'. 174908:save:Saving the backup data in the pool 'Index_Pool'. 175297:save: Unable to set up the direct save with server 'Server_Name': no matching devices for save of client `Server_Name'; check storage nodes, devices or pools. 175024:save: Cannot open a save session with NetWorker server 'Server_Name': no matching devices for save of client `Server_Name'; check storage nodes, devices or pools. 174921:save: Step (4 of 6) for PID-18603: Unable to connect to the target media device through the nsrmmd process for the save set 'index:c42c8a26-00000004-5bf6bdfd-5bf6bdfc-00015000-da5bbc56'.
The device used for the bootstrap or index backups is a remote device (rd=device_name); meaning it uses a remote storage node.
Cause
The NetWorker server index and bootstrap save sets cannot be backed up through a remote storage node device. This is as per the NetWorker Administration Guide. NetWorker guides are available through: https://www.dell.com/support/product-details/product/networker/docs
See Bootstrap backup on a storage node.
See Bootstrap backup on a storage node.
Resolution
The backup pool used for the Server db backup action must be associated with a local device. That is, a device created through the NetWorker server's local storage node.
If a local device is not available, create a new device using the NetWorker server's local storage node and label it to a new pool. Update the Server Protection -> Server backup -> Server db backup action to use the new pool.
If an additional copy is needed on a remote device, a post-backup clone action can be created to clone the save sets to a remote device.
If a local device is not available, create a new device using the NetWorker server's local storage node and label it to a new pool. Update the Server Protection -> Server backup -> Server db backup action to use the new pool.
If an additional copy is needed on a remote device, a post-backup clone action can be created to clone the save sets to a remote device.
Additional Information
If the device used is a local NetWorker server device and you are observing "check storage nodes, devices or pools," see: NetWorker: Troubleshooting Media Waiting Events - waiting for one writable volume or no matching devices
Affected Products
NetWorkerProducts
NetWorkerArticle Properties
Article Number: 000051782
Article Type: Solution
Last Modified: 22 Jun 2025
Version: 4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.