PowerStore: Remote System Data Connection State-partial_connectivity 0x01700303
Summary: This article outlines a recently identified issue with PowerStore Replication alerting for partial connectivity loss on the replication links. This issue is more likely to occur when the replication network is using a WAN environment as such environments typically experience higher latency. ...
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Alerts are received stating there is partial connectivity loss on remote connection <Dest. PowerStore> and within a short period of time, another alert is received stating the connection is restored. These alerts are seen both in the PowerStore UI and notification email messages.
No sessions were broken during the time frame of these alerts when looking at the replication sessions. Also, there are no other systems or applications within the network reporting connectivity issues.
Example of the alerts:
No sessions were broken during the time frame of these alerts when looking at the replication sessions. Also, there are no other systems or applications within the network reporting connectivity issues.
Example of the alerts:
Remote System Data Connection State (partial_connectivity) Error Code [0x01700303] Service Tag [XXXXXX] Appliance Name [appliance-1] Cluster Name [Cluster] Resource Type [remote_system] Resource Name [Cluster2] Severity [Major] Alert State [ACTIVE] Timestamp [2023-02-09T17:58:58.139441Z] Description: Some data connections from the remote system Cluster2 are disconnected. System Impact: Some or all replication/import sessions associated with the remote system may go into a system paused state. Some or all metro sessions associated with the remote system may go into fractured state. Repair Flow: Check and verify data network connectivity to your remote system %(remote_system_name) as per the best practise. Perform the Verify and Update operation to recover any connections. Reference: REMOTE_PROTECTION_REMOTE_SYSTEM_DATA_CONNECTION_STATE_PARTIAL_CONNECTIVITY [0x01700303]Followed up by the resolved alert within the same minute:
Remote System Data Connection State (ok) Error Code [0x01700302] Service Tag [XXXXXXX] Appliance Name [appliance-1] Cluster Name [Cluster] Resource Type [remote_system] Resource Name [Cluster2] Severity [Info] Alert State [CLEARED] Timestamp [2023-02-09T17:58:58.296624Z] Description: The remote system Cluster2 is operating normally. Reference: REMOTE_PROTECTION_REMOTE_SYSTEM_DATA_CONNECTION_STATE_OK [0x01700302]The frequency of these alerts can vary from thousands daily to only a few weekly.
Cause
These alerts are generated when PowerStore Replication sessions are lost, they may quickly recover but alerts are created for the temporary disconnect. If these events are quickly recovered this may not be an issue, though it is a symptom of a network-based issue.
Resolution
PowerStoreOS 4.0 is expected to reduce the frequency of the alerts though the events may still be occurring.
Workaround:
If you feel your issues match the issue described in this article, contact Dell Technical Support for PowerStore and reference this article.
As a possible workaround, it is recommended to implement QoS within the network for the replication link. This suggestion depends on the specific environment and may or may not reduce the number of alerts seen. It is also recommended to ensure that the remote connection network latency is configured as "High." This is located under the remote connection properties.
Some additional information to help confirm that the issue matches what is in this article:
- Does replication run over a WAN or LAN?
- Is WAN or LAN dedicated or shared?
- What is the link size or speed for the WAN or LAN?
- Are there other systems or applications reporting connectivity issues during the same time frame?
Affected Products
PowerStoreArticle Properties
Article Number: 000209430
Article Type: Solution
Last Modified: 29 Sept 2025
Version: 8
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.