The Data Protection Advisor Datastore service does not start when performing a new installation

Summary: The Data Protection Advisor Datastore service does not start when performing a new installation.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

The Data Protection Advisor Datastore appeared to install successfully as root, but afterwards the Datastore and Agent services failed to start.

Below are the errors and warnings observed.

Install log:

Installed the datastore service successfully

Command completed successfully.

Completed in : 89ms
[COMMAND EXIT CODE]
FAILURE : 255
[COMMAND OUTPUT]
EMC Data Protection Advisor

Completed in : 1.1secs
[COMMAND ERROR]
[ERROR] Cannot execute command as the service state is unknown. Service must be installed

[INFO] ---- Executing IASetApolloSuperUserPassword ----
[INFO] $CHOSEN_INSTALL_SET$ = (DS)
[INFO] $dpacmd$ = (/opt/emc/dpa/services/bin/dpa.sh)

[INFO] Executing 'dpa ds superpwd'..
[WARN] Executing 'dpa ds superpwd' was failed. The database superuser password was not set.

[INFO] ---- Executing ApolloUserPasswordConsole ----

[INFO] ---- Executing IASetApolloUserPassword ----
[INFO] $CHOSEN_INSTALL_SET$ = (DS)
[INFO] $dpacmd$ = (/opt/emc/dpa/services/bin/dpa.sh)

[INFO] Executing 'dpa ds dspassword'..
[WARN] Executing 'dpa ds dspassword' was failed. The database password was not set.

[COMMAND ERROR]
[ERROR] Failed to start the agent service

=======
# ./dpa.sh ds start --debug

EMC Data Protection Advisor

Environment variables are : []
[DEBUG] su: User not known to the underlying authentication module
[DEBUG] Service Conditions : false true false true
[DEBUG] Service State : UNKNOWN
[ERROR] Cannot execute command as the service state is unknown. Service must be installed

Also when a user attempting to uninstall the software, the uninstaller does not remove the files, scripts, or directories.

 

Cause

This is an environmental issue unrelated to Data Protection Advisor.

The issue is related to permissions on the Linux server. While the user may be "root," there are circumstances where this may not be sufficient still. There can also be other security software or requirements on the Linux server. These are managed by the Administrators of the Linux environment.

In one instance, it was observed that the Linux servers were configured with security software which prevented the DPA installer from creating the required user (apollosuperuser) and group (dpaservices) which are required by the DPA Datastore database.

 

Resolution

The DPA product is functioning as designed.

The resolution to this issue requires investigation by the Administrators of the affected environment. This should be investigated with the appropriate vendor if necessary.

For more information regarding permissions for installation on Linux, see the DPA Installation and Administration Guide. Review the section for System Requirements -> Permissions.

Contact Dell Technical Support for further details or information.

 

Products

Data Protection Advisor
Article Properties
Article Number: 000168546
Article Type: Solution
Last Modified: 25 Nov 2025
Version:  4
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