AppSync: Recovery fails due to mismatching SQL Server version s

Summary: Recovery fails with the error message "The SQL Server version of production instance is higher than the version of mount instance. Recovery cannot be initiated if the versions on both the servers do not match." ...

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Symptoms

Updated AppSync from 3.x to 3.7 or later and also updated the Product host agent but not the Mount host agent.

After upgrading from AppSync 3.5 to AppSync 3.7 or later, Service Plans may fail during the recovery phase. The error below can be seen in the AppSync GUI.

Error seen in the Service Plan events: 
The SQL Server version <Version Number> of production instance is higher than the version <Version Number> of mount instance. Recovery cannot be initiated if the versions on both the servers do not match.

Error seen in Server logs: 
02-22-2018 21:44:27.198 INFO [EJB default - 5] [com.emc.archway.service.eventservice.EventServiceBean] [Host_Name] [] d1xxxxxxxxxxxxxxxxxxxxxxxxxxx->>> EVENT [SQL_000028]:  The SQL Server version <Version Number> of production instance ABC is higher than the version <Version Number> of mount instance XYZ . Recovery cannot be initiated if the versions on both the servers do not match.(METADATA: TYPE-ERROR, TIME-2018-02-22 21:44:27.198-0800NATIVETIME-2018-02-22 21:44:27.198-0800, HOST-Host_ Name, PHASE-Recover copy, THREAD=EJB default - 5, USER-User_Name, CATEGORY-GENERIC, SESSIONID-f4-20V8nudbHq8155MOFFTZkHayb1PYEgeAaELoj)
02-22-2018 21:44:27.198 ERROR [EJB default - 5] [com.emc.archway.commands.application.RunApplicationRecoveryCommandBean] [Host_Name] [] d1xxxxxxxxxxxxxxxxxxxxxxxxxxx->>> Exception Occurred: IncompatibleSqlInstanceVersion, Message:  The SQL Server version <Version Number> of production instance ABC is higher than the version <version Number> of mount instance XYZ. Recovery cannot be initiated if the versions on both the servers do not match.

Cause

This may be seen in the following circumstances: 
  • The SQL Server version at both production and mount host may be same, but has SQL Server has Cumulative Update or Service Pack installed which leads to an increment in minor number of SQL Instance version.
  • Production host is running AppSync 3.7 and Mount Host is running 3.5 or earlier. Recovery will fail due to AppSync detecting a version mismatch if the Mount host is not running AppSync Agent version 3.7.
Prior to AppSync 3.7, AppSync showed only base SQL Instance version. After upgrading AppSync version to 3.7 it will show SQL instance version which will identify the SQL version along with any Service Pack or Cumulative Update installed on it.

Resolution

Workaround: 
  1. Verify the AppSync Host Plug-in version installed on Production Host and Mount host.
  2. The AppSync Host Plug-in version on Mount Host must be the same as of the Production Host.
  3. If there is AppSync version mismatch, then update the Host plug-in in Mount Host and Rediscover the Host in AppSync Server.

Products

AppSync
Article Properties
Article Number: 000167338
Article Type: Solution
Last Modified: 18 Sept 2025
Version:  5
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