NetWorker: Restore failed with message not properly configured on the NetWorker Server
Summary: NetWorker browsable restore failed with "not properly configured" message, while saveset recovery success
Symptoms
Naming change after implementation or removed names, or both
Using NetWorker Server recovery tab or NetWorker user UI, the browsable recovery of file or directory for certain clients failed with "not properly configured on the NetWorker Server" message.
The reported message related to client that different from the source or target restore clients
The reported message related to a client that was not configured and unknown for NetWorker.
Using saveset recovery success.
Cause
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Nested index issue, which the index folder for the client (client.emc.com) reported the following:
<client.emc.com> |__Client.emc.com |__db6 |... |...
You notice from the above, that the nested index folder start with the client name upper case
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Problem with nsrladb
The client nsrlad, the NSR resource have unknown client name reported in the administrator list.
Resolution
On the NetWorker server host, browse to the index folder and locate the problematic client.
Browse the problematic client and delete the nested folder of the client with the upper case:
Client.emc.com
Run "nsrck -L6 client.emc.com" command.
Once the above command completes, log in to the problematic client host
Run "nsradmin -p nsrexec" and verify the NSR resources. Check the administrator list for the unknown client name.
Shut down the NetWorker Services on the client.
Rename the nsrladb.
Start the NetWorker services.
Verify the NSR resource ok.
Start the browsable restore.