Data Protection Advisor (DPA): Application service failed to contact Datastore service after host reboot
Summary: This article provides resolution when application service failed to contact Datastore service after host reboot.
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This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Failed to start Data Protection Advisor (DPA) application service after Linux DPA application server system reboot.
Following error message received if we manually start DPA app service via dpa app start:
Failed to contact datastore service on host: x.x.x.x
[ERROR] Failed to validate datastore availability. Please check connectivity.
Unable to telnet to port 9003 on the Datastore server.
Following error message received if we manually start DPA app service via dpa app start:
Failed to contact datastore service on host: x.x.x.x
[ERROR] Failed to validate datastore availability. Please check connectivity.
Unable to telnet to port 9003 on the Datastore server.
Cause
Linux iptables automatically enabled after DPA app server system reboot.
This can be verified by running below command on DPA app server:
service iptables status
This can be verified by running below command on DPA app server:
service iptables status
Resolution
Stop iptables on DPA application server using the command "service iptables stop".
Engage admin group responsible to disable iptables at system startup or edit iptables rules to allow the ports used by DPA.
Engage admin group responsible to disable iptables at system startup or edit iptables rules to allow the ports used by DPA.
Affected Products
Data Protection AdvisorProducts
Data Protection AdvisorArticle Properties
Article Number: 000053425
Article Type: Solution
Last Modified: 09 Oct 2024
Version: 4
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