DPA: Agent Fails to Connect to Avamar Server, Error "Failed to determine database version"
Summary: Data Protection Advisor (DPA) agent fails to connect to Avamar Server. Agent log error "Failed to determine database version: Connection to database mcdb failed: could not connect to server: Connection timed out" ...
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Symptoms
Data collection is failing for an Avamar server.
Examining the DPA Agent log or the request history screen you see the following error:
DBG1 9695.8 20170403:115705 sodbc.pgsql.connect - cpgsqlConnect(): Failed to determine database version: Connection to database mcdb failed: could not connect to server: Connection timed out Is the server running on host "test.avamar" (192.xxx.x.xx) and accepting TCP/IP connections on port 5555?
Cause
This error indicates that the DPA agent is not able to establish a connection to the Avamar server.
Some environmental factors unrelated to DPA including may cause this issue:
- Network connectivity issues
- Name resolution issues
- Avamar connection configuration issues
Resolution
The following steps can be used to test for network connectivity:
- Ping the Avamar from the DPA Agent server. If there is no response, then this is a network problem.
- If a response to the ping is received, then from a Linux system or Windows PowerShell you can run the following to test the port connection:
curl -kv <avamar FQDN or IP>:5555
- In a good response where the port is reachable, the "Connected to" line is there showing a connection was made. See example below:
curl -kv 10.x.x.x:5555 * Trying 10.x.x.x:5555... * Connected to 10.x.x.x (10.x.x.x) port 5555 (#0) > GET / HTTP/1.1 > Host: 10.x.x.x:5555 > User-Agent: curl/8.0.1 > Accept: */* > * Empty reply from server * Closing connection 0 curl: (52) Empty reply from server
- If the "Connected to " line is not there, or you get "Failed to Connect," "Not Connected" or it stops responding and does not give a return, this indicates a network connection issue.
- This requires investigation by the Network Administrator of the environment to resolve the network connection issue.
- If the Curl command connects, then open a Service Request (SR) with Dell Support.
Contact Dell Support for further details or information.
Affected Products
Data Protection AdvisorProducts
AvamarArticle Properties
Article Number: 000059572
Article Type: Solution
Last Modified: 23 Jul 2025
Version: 4
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