Data Protection Advisor (DPA): La solicitud de recopilación de datos continúa agotando el tiempo de espera después de aumentar el valor de tiempo de espera del comando
Summary: Data Protection Advisor (DPA): La solicitud de recopilación de datos mantiene el tiempo de espera agotado aunque los valores de tiempo de espera ya aumentaron
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Symptoms
Las solicitudes de recopilación de datos continúan fallando con errores de tiempo de espera después de aumentar el valor de tiempo de espera agotado del comando para la solicitud
Cause
El valor de tiempo de espera agotado del comando ajustable en la GUI controla cuánto tiempo esperará la solicitud para que se complete cada comando individual emitido por la solicitud antes de generar un error de tiempo de espera agotado. Hay una configuración de Tiempo de espera de solicitud adicional que controla cuánto tiempo esperará la solicitud a que se completen todos los comandos que ejecuta la solicitud y también se debe aumentar este valor. El valor de Tiempo de espera agotado de solicitud es de una hora de manera predeterminada y no se puede ajustar dentro de la GUI.
Resolution
El valor de Tiempo de espera agotado de solicitud se puede aumentar mediante la actualización de dpaagent_config.xml, que tiene la siguiente ubicación predeterminada:
Linux: <Install Directory>/agent/etc/dpaagent_config.xml
Windows: <Install Directory>\agent\etc\dpaagent_config.xml Antes de
editar dpaagent_config.xml, asegúrese de hacer una copia del archivo en caso de que sea necesario revertirlo.
A continuación, se muestra un ejemplo del archivo dpaagent_config.xml:
<AGENTCONFIG><VERSION>600</VERSION>
<AGENTVERSION>18 2.0.1579597783</AGENTVERSION>
<SERVERNAME>DPA-APP-EXAMPLE-SERVER</SERVERNAME>DPA-APP-EXAMPLE-SERVER</SERVERNAME>
> <SERVERPORT>9002</SERVERPORT>
<SERVERSSL>true</SERVERSSL>
<LOGFILE>/opt/emc/dpa/agent/logs/dpaagent.log</LOGFILE>
<LOGLEVEL>Info</LOGLEVEL>
</AGENTCONFIG> Se deberá agregar la siguiente etiqueta dpaagent_config.xml para aumentar el valor de Tiempo de espera agotado de
solicitud:
<REQUESTTIMEOUT>Value</REQUESTTIMEOUT> Tenga en cuenta que el valor de tiempo de
espera se establece en segundos. El tiempo de espera agotado de solicitud se debe configurar en un valor que permita que la solicitud se complete correctamente. A continuación, se muestra un ejemplo de un dpaagent_config.xml con el valor Request Timeout configurado en 24 horas:
<AGENTCONFIG><VERSION>600</VERSION>
<AGENTVERSION>18.2.0.1579597783</AGENTVERSION>
<SERVERNAME>DPA-APP EJEMPLO: SERVER</SERVERNAME>
<SERVERPORT>9002</SERVERPORT>
<SERVERSSL>true</SERVERSSL>
<LOGFILE>/opt/emc/dpa/agent/logs/dpaagent.log</LOGFILE>
< LOGLEVEL>Info</LOGLEVEL>
<REQUESTTIMEOUT>86400</REQUESTTIMEOUT>
</AGENTCONFIG>Once
se actualizó dpaagent_config.xml, reinicie los servicios
del agente de DPA para que el nuevo valor de Tiempo de espera agotado de solicitud esté habilitado. Comuníquese con el soporte técnico de Dell EMC para obtener más detalles o información.
Linux: <Install Directory>/agent/etc/dpaagent_config.xml
Windows: <Install Directory>\agent\etc\dpaagent_config.xml Antes de
editar dpaagent_config.xml, asegúrese de hacer una copia del archivo en caso de que sea necesario revertirlo.
A continuación, se muestra un ejemplo del archivo dpaagent_config.xml:
<AGENTCONFIG><VERSION>600</VERSION>
<AGENTVERSION>18 2.0.1579597783</AGENTVERSION>
<SERVERNAME>DPA-APP-EXAMPLE-SERVER</SERVERNAME>DPA-APP-EXAMPLE-SERVER</SERVERNAME>
> <SERVERPORT>9002</SERVERPORT>
<SERVERSSL>true</SERVERSSL>
<LOGFILE>/opt/emc/dpa/agent/logs/dpaagent.log</LOGFILE>
<LOGLEVEL>Info</LOGLEVEL>
</AGENTCONFIG> Se deberá agregar la siguiente etiqueta dpaagent_config.xml para aumentar el valor de Tiempo de espera agotado de
solicitud:
<REQUESTTIMEOUT>Value</REQUESTTIMEOUT> Tenga en cuenta que el valor de tiempo de
espera se establece en segundos. El tiempo de espera agotado de solicitud se debe configurar en un valor que permita que la solicitud se complete correctamente. A continuación, se muestra un ejemplo de un dpaagent_config.xml con el valor Request Timeout configurado en 24 horas:
<AGENTCONFIG><VERSION>600</VERSION>
<AGENTVERSION>18.2.0.1579597783</AGENTVERSION>
<SERVERNAME>DPA-APP EJEMPLO: SERVER</SERVERNAME>
<SERVERPORT>9002</SERVERPORT>
<SERVERSSL>true</SERVERSSL>
<LOGFILE>/opt/emc/dpa/agent/logs/dpaagent.log</LOGFILE>
< LOGLEVEL>Info</LOGLEVEL>
<REQUESTTIMEOUT>86400</REQUESTTIMEOUT>
</AGENTCONFIG>Once
se actualizó dpaagent_config.xml, reinicie los servicios
del agente de DPA para que el nuevo valor de Tiempo de espera agotado de solicitud esté habilitado. Comuníquese con el soporte técnico de Dell EMC para obtener más detalles o información.
Affected Products
Data Protection AdvisorProducts
Data Protection AdvisorArticle Properties
Article Number: 000069191
Article Type: Solution
Last Modified: 23 Sep 2024
Version: 3
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