APEX Multi Cloud Platform for Azure | AzureEdgeRemoteSupport Showing as Failed in the Azure Portal
Summary: After APEX Multi-Cloud Platform for Azure deployment (version 1.01), AzureEdgeRemoteSupport shows as Failed in the Azure Portal.
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Symptoms
After APEX Multi-Cloud Platform for Azure deployment (version 1.01), AzureEdgeRemoteSupport shows as Failed in the Azure Portal. This setting is found in the Resource Group of the cluster. It is found under Settings -> Extensions.


Cause
This is a Microsoft known issue. AzureEdgeRemoteSupport(Azure-managed) extension shows "Failed" in the Azure portal after the cluster finished deployment.
The remote support extension is working but there is an active service-side issue due to a mismatch in the name of the extension "EdgeRemoteSupport" vs "AzureEdgeRemoteSupport."
The remote support extension is working but there is an active service-side issue due to a mismatch in the name of the extension "EdgeRemoteSupport" vs "AzureEdgeRemoteSupport."
Resolution
Microsoft is working on a fix from the Azure cloud but for now, they have said that it can be ignored.
Alternatively, if the user does not want to wait for the fix to be applied automatically the following can be done:
1. Go to each ARC HCI node on the ARC machine blade in the portal.
2. Uninstall the Remote Support extension with the wrong name.
3. Trigger a force sync from any of the nodes in the cluster by running:
Alternatively, if the user does not want to wait for the fix to be applied automatically the following can be done:
1. Go to each ARC HCI node on the ARC machine blade in the portal.
2. Uninstall the Remote Support extension with the wrong name.
3. Trigger a force sync from any of the nodes in the cluster by running:
sync-azurestackhci4. HCI RP re-installs the extension with the correct name, and the failures on the HCI blade should go away.
Affected Products
APEX Cloud Platform for Microsoft AzureArticle Properties
Article Number: 000223559
Article Type: Solution
Last Modified: 11 Apr 2024
Version: 2
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