PowerFlex Management Platform: Add Network wizard fails with error VXFM0004

Summary: The "Add Network" Wizard to add workload VLANs to a CO RG is failing with the error VXFM0004.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Using the "Add Network" Wizard for a CO RG is failing with the error VXFM0004.
When clicking finish in the "Add Network" Wizard, the UI loads then fails with the below error:
vxfm0004 error in the Add Network wizard

An error occurred. Expand the list to view the details of the error. (500)
The operation cannot be performed because of an internal issue. (VXFM0004)

asmManager pod log
When "Finish" is clicked, the following log entries are seen:

This same error is seen when attempting to run an "Add Existing Resource Group" operation.

"messages" : [ {
  "id" : null,
  "messageCode" : "IDENTITYPOOLMANAGER.0001",
  "messageBundle" : "IdentityPoolManager",
  "severity" : "ERROR",
  "category" : "USER_FACING",
  "displayMessage" : "The record ID <ID> cannot be retrieved because it is not in the database.",
  "responseAction" : "Enter the correct record ID, and then retry the operation.",
  "detailedMessage" : "The application cannot find the record ID identified in the message because it is not present in the database.",
  "correlationId" : null,
  "agentId" : null,
  "timeStamp" : "Date",
  "sequenceNumber" : 0
} ]

Impact 

The mentioned error has been observed impacting automated orchestration tasks such as "Add Network" and "Add Existing Resource Group" and may affect other tasks.

 

Cause

The error indicates that the asmManager has cached a record ID that no longer exists.

When automation tasks are queued and start, the asmManager pod sees this orphaned ID, leading to an error due to the ID missing from the database.

 

Resolution

Here are the steps to resolve this issue:

  1. Remove the RG that is encountering the error: VXFM0004
    Make note of the RG name and networks

  2. On an MVM, run the following command to re-create a new asmManager pod:

    kubectl delete pod -n powerflex $(kubectl get pods -n powerflex|grep asmm|awk '{print $1}')
  3. Re-run the "Add Networks" wizard.

Impacted Version

PFMP 4.5.2

Fixed In Version

PFMP 4.8

 

Affected Products

PowerFlex rack, PowerFlex Appliance, PowerFlex Software
Article Properties
Article Number: 000228269
Article Type: Solution
Last Modified: 17 Jun 2025
Version:  3
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