PowerProtect Data Manager File System Agent Registration Failed Due to Reverse IP Lookup Configuration Issue

Summary: PowerProtect Data Manager File System agent registration fails due to reverse IP lookup configuration issue. The agent registration fails after new installation when reverse IP lookup is not configured. To resolve the issue, configure reverse IP lookup on the DNS server or modify the hosts file temporarily. ...

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Symptoms

PowerProtect Data Manager File System agent registration failed after new installation

From the PowerProtect Data Manager UI > Application Agents > Registration Status, it shows Failed after Accepting Certificates.

Screen shot of Application Agent with status "Accepting Certificates"

Screen shot of Application Agents with status "Failed"

In C:\Program Files\DPSAPPS\AgentService\logs\OpAgentSvc-******.log, it shows the below PPDM IpCheck validation failed for /greetings call.

[2024-10-21 03:53:05,643 GMT| 2024-10-21 11:53:05,643506 | DBGHTTPSERVER| PID-2796| TID-3564| INFO] C:\Program Files\DPSAPPS\AgentService\tmp_MEI50402\Http\HTTPServer.pyc-checkIP()-Line 361- Could not fetch the host details for the address ppdm.local.com
[2024-10-21 03:53:05,643 GMT| 2024-10-21 11:53:05,643506 | DBGHTTPSERVER| PID-2796| TID-3564| INFO] C:\Program Files\DPSAPPS\AgentService\tmp_MEI50402\Http\HTTPServer.pyc-checkIP()-Line 362- PPDM IpCheck validation failed. Rejecting the api call for /greetings
[2024-10-21 03:53:24,449 GMT| 2024-10-21 11:53:24,449717 | DBGHTTPSERVER| PID-2796| TID-3564| ERROR] C:\Program Files\DPSAPPS\AgentService\tmp_MEI50402\Http\HTTPServer.pyc-startWSGIServer()-Line 5658- Timeout error occurred, exiting registration process exit code 7. Error - 3600 seconds
Traceback (most recent call last):
File "Http\HTTPServer.py", line 5656, in startWSGIServer
File "Http\HTTPServer.py", line 5503, in start_server
File "src\\gevent\\greenlet.py", line 1065, in gevent._gevent_cgreenlet.joinall
File "src\\gevent\\greenlet.py", line 1075, in gevent._gevent_cgreenlet.joinall
File "src\\gevent\_hub_primitives.py", line 250, in gevent._gevent_c_hub_primitives.wait_on_objects
File "src\\gevent\_hub_primitives.py", line 287, in gevent._gevent_c_hub_primitives.wait_on_objects
File "src\\gevent\_hub_primitives.py", line 185, in gevent._gevent_c_hub_primitives._WaitIterator.__next__
File "src\\gevent\_hub_primitives.py", line 176, in gevent._gevent_c_hub_primitives._WaitIterator.__next__
File "src\\gevent\_waiter.py", line 195, in gevent._gevent_c_waiter.MultipleWaiter.get
File "src\\gevent\_waiter.py", line 154, in gevent._gevent_c_waiter.Waiter.get
File "src\\gevent\_greenlet_primitives.py", line 61, in gevent._gevent_c_greenlet_primitives.SwitchOutGreenletWithLoop.switch
File "src\\gevent\_greenlet_primitives.py", line 61, in gevent._gevent_c_greenlet_primitives.SwitchOutGreenletWithLoop.switch
File "src\\gevent\_greenlet_primitives.py", line 65, in gevent._gevent_c_greenlet_primitives.SwitchOutGreenletWithLoop.switch
File "src\\gevent\_gevent_c_greenlet_primitives.pxd", line 35, in gevent._gevent_c_greenlet_primitives._greenlet_switch
gevent.timeout.Timeout: 3600 seconds
[2024-10-21 03:53:24,449 GMT| 2024-10-21 11:53:24,449717 | DBGHTTPSERVER| PID-2796| TID-3564| INFO] C:\Program Files\DPSAPPS\AgentService\tmp_MEI50402\Http\HTTPServer.pyc-startWSGIServer()-Line 5660- Please follow the remediation steps mentioned below to resolve the problem :
1. Check if the host is approved/whitelisted on PowerProtect Data Manager server.
2. Alternatively, 'Auto Allow List' can be enabled on PowerProtect Data Manager server.
3. Ensure there is no connectivity issue from PowerProtect Data Manager server to agent system.
4. Restart the agent service and try again.
[2024-10-21 03:53:25,230 GMT| 2024-10-21 11:53:25,230570 | AGENTSVC_OP| PID-4320| TID-6672| ERROR] C:\Program Files\DPSAPPS\AgentService\tmp_MEI50402\main.py-checkHttpServer()-Line 949- HTTPServer has stopped with exitcode 7.
[2024-10-21 03:53:25,230 GMT| 2024-10-21 11:53:25,230570 | AGENTSVC_OP| PID-4320| TID-6672| ERROR] C:\Program Files\DPSAPPS\AgentService\tmp_MEI50402\main.py-checkHttpServer()-Line 951- Stopping the agentService

Cause

The root cause of the PowerProtect Data Manager File System agent registration failure is attributed to the absence of reverse IP lookup configuration. Run nslookup on the client side to verify the name resolution of the PowerProtect Data Manager. It works for the PowerProtect Data Manager hostname, but not for the reverse IP lookup. 

nslookup output for the hostname

nslookup output for the IP

It is documented in the PowerProtect Data Manager File System User Guide that "Name resolution and reverse IP lookup must be configured" 

PPDM File System User Guide

Resolution

The resolution is to configure the reverse IP lookup of PowerProtect Data Manager on a DNS server. If the DNS server is not accessible at this moment, temporarily modify the hosts file on the client side. After that, the Registration Status in the UI should be changed to Awaiting Approval automatically. If not, restart the PowerProtect Agent Service on the client side manually.

PowerProtect Agent Service on the client side

Affected Products

PowerProtect Data Manager
Article Properties
Article Number: 000239282
Article Type: Solution
Last Modified: 16 Dec 2024
Version:  2
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