Ethernet Port on Dell Dock is not Detected when Dock is Connected to the USB Port On Dell Pro Computers

Summary: This article is about Dell Pro computers not detecting the LAN port on Dell Docks, when connected to the USB port instead of the Thunderbolt port.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Affected Platforms:

  • Dell Pro 14 PC14250
  • Dell Pro 16 PC16250

If Enable External USB Port is disabled and Type-C Dock LAN is enabled, the dock's LAN port does not work when the dock is connected to the Type-C USB 3.2 Gen 2 port (Front side, near audio jack).

Cause

This is a limitation of the Dell Pro 14 and 16 hardware design. The Type-C USB 3.2 Gen 2 port (Front side, near audio jack) cannot be functionally controlled through TCSS for Type-C Dock Override on Dock LAN.

Resolution

Remove the Dell Dock from the computer and connect it to the Thunderbolt 4.0 port (Rear side, near HDMI). The Dell Dock Ethernet LAN then functions properly.

Dell Pro 14 PC14250 and Dell Pro 16 PC16259 left side view:

Dell Pro 14 PC14250 and Dell Pro 16 PC16259 left side view

Note:
  1. Power-adapter port
  2. Battery-status light
  3. HDMI 2.1 Transition-minimized differential signaling (TMDS) port
  4. Thunderbolt 4.0 port with DisplayPort and Power Delivery
  5. USB 3.2 Gen 2 Type-C port with DisplayPort 1.4a and Power Delivery
  6. Global headset port

Affected Products

Dell Pro 14 PC14250, Dell Pro 16 PC16250
Article Properties
Article Number: 000315970
Article Type: Solution
Last Modified: 15 Sep 2025
Version:  2
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