Skip to main content
  • Place orders quickly and easily
  • View orders and track your shipping status
  • Enjoy members-only rewards and discounts
  • Create and access a list of your products
  • Manage your Dell EMC sites, products, and product-level contacts using Company Administration.

Dell PowerEdge Systems Red Hat Enterprise Linux 8 Release Notes

PowerEdge servers with the AMD Rome processor fail to detect an NVMe drive after multiple hot plugs

Description
The PowerEdge servers with the AMD Rome processor fail to detect an NVMe drive after multiple hot plugs.
Cause
Issue in pciehp driver.
Workaround
NOTE:The output of each command varies based on your system configuration.
Follow the steps:
  1. Identify the parent device to which the NVMe device is connected using the following command:
    lspci -t
    
    -+-[0000:e0]-+-00.0
    |           +-00.2
    |           +-01.0
    |           +-02.0
    |           +-03.0
    |           +-03.1-[e2]----00.0
    
    From the above snippet, the device e2:00.0 is the NVMe device and the device e0:03.1 is the parent device. The parent device is used for the steps that are described subsequently.
  2. Read the Slot Status Register in the PCI Express Capability structure by running the following command:
    setpci -s e0:03.1 CAP_EXP+0x1a.w
    Output: 0148 (value returned)
  3. Clear the event bits that are impacted by running the following command:
    setpci -s e0:03.1 CAP_EXP+0x1a.w=0x0108
  4. Re-read the Slot Status Register to confirm that event bits are cleared by running the following command:
    setpci -s e0:03.1 CAP_EXP+0x1a.w
    Output: 0040 (value returned)
  5. Unplug the drive and then plug-in the drive after clearing the event bits.
Solution
The issue is resolved in Red Hat Enterprise Linux 8.2 z-stream kernel version kernel-4.18.0-193.13.2.el8_2.x86_64 and later
Systems affected
PowerEdge R6515, PowerEdge R7515, PowerEdge R6525, PowerEdge C6525, and PowerEdge R7525
Applies to

Red Hat Enterprise Linux 8

Tracking number
155501, 155503

Rate this content

Accurate
Useful
Easy to understand
Was this article helpful?
0/3000 characters
  Please provide ratings (1-5 stars).
  Please provide ratings (1-5 stars).
  Please provide ratings (1-5 stars).
  Please select whether the article was helpful or not.
  Comments cannot contain these special characters: <>()\