Unity: VNX: ESXi Host grab uploaded to create a Host Report run-through "My-Work" is missing HBA information.

Summary: ESXi Host Report run through the Dell Technologies Central website "https://psapps.emc.com/central/my-work" is missing HBA information.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

When the grab file is uploaded to the site in order to generate a host report, the report is created but is missing HBA information about the report. The report shows "None" under the HBA section. 

Cause

There is a problem with the Host CIM (Common Information Model) agent or CIM provider API.

Resolution

First, for ESXi ensure that the host's CIM (Common Information Model) agent is enabled.

Reference the following VMware article and using CLI ensures that the CIM agent is enabled by running the 'esxcli system wbem set --enable true' command.

How to disable or enable the CIM agent on the ESX/ESXi host
https://kb.vmware.com/s/article/1025757

Once confirmed, run a new Host grab and upload that to the My-work site again and check the HBA information.
If you now have HBA information showing in the report you need go no further.

However, If there is still no HBA information, it's likely that the HBA CIM provider on the host is not installed and you will have to do a web search using the HBA vendor name + CIM provider as your keywords to find the appropriate download.

If HBA is Qlogic you can find CIM drivers here:
http://driverdownloads.qlogic.com/QLogicDriverDownloads_UI/

Search for CIM Provider driver on the HBA vendor website, if applicable check with your Host vendor to be sure that an offline maint. window is not needed.

If confirmation that CIM (Common Information Model) provider is needed, then it may be necessary to engage DTST tools support team which the Grabs, ELA, Central and 'My work' fall under. DTST tools team may be engaged using the Central website:  https://psapps.emc.com/central/  
Find the '?' icon in the upper right-hand corner of the page and select:  'Support' from the 'Help & Support' dropdown.  
Fill out the form and a support representative will reach out to you using email with an SR number for follow-up.
DTST team must see an ESXi Grab debug output file to verify the issue. 

To run ESXi debug.log output file:
Similar to running the regular ESXi Host Grab you would run the executable with the -debug switch like in the following example:

esxigrab.exe -host x.x.x.x -user root -password <password> -autoexec -legal -debug > debug.log

Once you have the debug.log output file, attach the file to the Service Request or ask the SR owner for an FTP for upload.

Additional Information

Note: The Host vendor for this use case was ESXi, however this issue could also apply to other Hosts, such as Windows, Linux or AIX as well.  You must search for that particular vendor's CIM Provider download site and/or CIM agent enable command information if having a similar issue.

Affected Products

Storage, Dell EMC Unity, VNX/VNXe, VMware
Article Properties
Article Number: 000182981
Article Type: Solution
Last Modified: 12 ديسمبر 2025
Version:  3
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