NetWorker: All backups sent to Data Domain are failing with "no matching devices for save of client"

Summary: Backups are failing with "no matching devices for save of client '[client_name]'; check storage nodes, devices, or pools" but all configurations are correct.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

  • All backups sent to Data Domain start failing with "no matching devices."
  • The NetWorker Management Console (NMC) reports:
no matching devices for save of client '[client_name]'; check storage nodes, devices or pools
  • The NetWorker Server daemon.raw reports the following error:
SYSTEM critical Failed to connect to [Data_Domain]
  • When testing the connection to the DD, all connection test (ping, nslookup, and so forth) comes back fine.

Cause

The ddboost user password had expired which caused the account to be locked.

Resolution

Update the ddboost user password.

1. In a web browser, go to the Data Domain user interface: https://DD_ADDRESS
2. Log in with the sysadmin account.
2. Click Administration -> Access, then click Local Users.
3. Select the ddboost user account used by the NetWorker devices.
4. Click Change Password

5. Ensure the ddboost user account shows Enabled, if locked or disabled, click Enable.
6. Log in to the NetWorker Management Console.
7. Go to Devices->Devices.
8. For each device configured against the affected Data Domain, update the ddboost user password.

NetWorker device password

9. Ensure that the device can be mounted. 
10. Rerun the failed job.

Additional Information

This error has other potential causes. If the ddboost account is not locked, see: NetWorker: Troubleshooting Media Waiting Events - waiting for one writable volume or no matching devices

Affected Products

NetWorker

Products

NetWorker Family
Article Properties
Article Number: 000052953
Article Type: Solution
Last Modified: 14 Aug 2025
Version:  5
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