Avamar: VM Backup, Restore Fails "Cannot establish connection with server" avtar Error 10541

Summary: Avamar VM Image backups are failing with error 10026.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Multiple errors occur inside both the avvcbimage.log file, and the avtar.log file.

  • Avvcbimage.log
avvcbimage Warning <6653>: CTL workorder "MOD-1289960020340" non-zero exit status 'code 158: Cannot establish connection with server (possible network or DNS failure)'
  • Avtar.log
avtar Error <10541>: Failed to resolve Data Domain Server name

Cause

Avamar VMware Proxy cannot resolve the Data Domain server.

    Resolution

    The DNS entries (/etc/resolv.conf) on the Avamar VMware Proxy must be reviewed.


    Troubleshooting Instructions: 

    1. SSH to proxy in question
    2. From the error avtar Error <10541>, record the Data Domain hostname.
    3. Run the following command on the proxy (replace DataDomainHostname with the Data Domain hostname). This uses the configured nameservers in /etc/hosts and checks if the Data Domain can be resolved.
    grep -oP '(?<=^nameserver\s)\S+' /etc/resolv.conf | xargs -I{} sh -c 'echo -n "{}: "; nslookup "DataDomainHostname" {} >/dev/null && echo "OK" || echo "FAIL"'
    1. If the name resolution fails, determine if the configured nameservers are correct. 
    • When the entries are correct and Data Domain hostname cannot resolve, investigate the Proxy's configured IP information, and redeploy with correct values. 
    • If they are NOT correct, redeploy the proxies with the correct DNS entries.

    Affected Products

    Avamar

    Products

    Avamar, Avamar Client for VMware
    Article Properties
    Article Number: 000037896
    Article Type: Solution
    Last Modified: 17 Dec 2025
    Version:  5
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