PowerProtect Data Manager: La VM del motore di ricerca è bloccata in modalità di riavvio

Summary: Il motore di ricerca non è operativo, è irraggiungibile e bloccato in modalità di riavvio.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Impossibile avviare la VM motore di ricerca ed è bloccata in modalità di riavvio.

Dall'interfaccia utente di PowerProtect Data Manager, il cluster non è operativo in quanto uno o più nodi si trovano in uno stato di errore.

Schermata del messaggio di errore del motore di ricerca
Figura 1.
 Schermata del messaggio di errore del motore di ricerca

Cause

La root cause del problema è che la directory /tmp è piena sulla VM del motore di ricerca che influisce sul sistema operativo. 

Resolution

Nella versione 19.12 di PowerProtect Data Manager, le dimensioni della directory /tmp nel motore di ricerca non sono monitorate. Questo problema è stato risolto nella release 19.13.

Soluzione:

  1.  Eseguire l'SSH in PowerProtect Data Manager e passare all'utente root.
  2. Ottenere le credenziali della VM del motore di ricerca con i seguenti comandi
source /opt/emc/vmdirect/unit/vmdirect.env  && 
/opt/emc/vmdirect/bin/infranodemgmt get -secret
  1. Connettersi a vCenter e aprire la remote console per la VM del nodo di ricerca. Utilizzare la modalità utente singolo per accedere. 181219 dell'articolo Dell, software PowerProtect: Come reimpostare la password root di PPDM dalla modalità utente singolo fornisce la procedura per accedere alla VM in modalità utente singolo.
  2. Verificare che la directory /tmp sia piena. Eseguire i comandi seguenti:
  • Eseguire il comando seguente per controllare lo spazio disponibile nella directory /tmp:
df -h /tmp
  • Eseguire il comando seguente per trovare i primi 10 file più grandi nella directory /tmp:
sudo find /tmp -type f -printf '%s %p\n' | sort -nr | head -10
  1. Rimuovere i file più grandi e quindi eseguire nuovamente il comando seguente per verificare se c'è spazio sufficiente nella directory /tmp.
df -h /tmp
  1. Riavviare la VM del motore di ricerca. 
  2. Controllare lo stato del motore di ricerca in PowerProtect Data Manager e verificare che sia operativo.
Article Properties
Article Number: 000214547
Article Type: Solution
Last Modified: 14 Jun 2023
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.