PowerProtect Data Manager: 재시작 모드에서 검색 엔진 VM이 중단됨

Summary: 검색 엔진이 작동하지 않고, 연결할 수 없으며, 재시작 모드로 중단되었습니다.

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Symptoms

검색 엔진 VM을 시작할 수 없으며 재시작 모드로 중단되었습니다.

PowerProtect Data Manager UI에서 하나 이상의 노드가 장애가 발생한 상태이므로 클러스터가 작동하지 않습니다.

검색 엔진 오류 메시지 스크린샷
그림 1:
 검색 엔진 오류 메시지 스크린샷

Cause

이 문제의 근본 원인은 운영 체제에 영향을 미치는 검색 엔진 VM에 /tmp 디렉토리가 가득 차 있다는 것입니다. 

Resolution

PowerProtect Data Manager 버전 19.12에서는 검색 엔진의 /tmp 디렉토리 크기가 모니터링되지 않습니다. 이 문제는 19.13 릴리스에서 해결되었습니다.

해결:

  1.  PowerProtect Data Manager로 SSH를 수행하고 루트 사용자로 승격합니다.
  2. 다음 명령을 사용하여 검색 엔진 VM 자격 증명 가져오기
source /opt/emc/vmdirect/unit/vmdirect.env  && 
/opt/emc/vmdirect/bin/infranodemgmt get -secret
  1. vCenter에 연결하고 검색 노드 VM에 대한 원격 콘솔을 엽니다. 단일 사용자 모드를 사용하여 로그인합니다. Dell 문서 181219, PowerProtect 소프트웨어: 단일 사용자 모드에서 PPDM 루트 암호를 재설정하는 방법은 단일 사용자 모드에서 VM에 액세스하는 방법에 대한 단계를 제공합니다.
  2. /tmp 디렉토리가 가득 찼는지 확인합니다. 다음 명령을 실행합니다.
  • 다음 명령을 실행하여 /tmp 디렉토리에서 사용 가능한 공간을 확인합니다.
df -h /tmp
  • 다음 명령을 실행하여 /tmp 디렉토리에서 상위 10개 파일을 찾습니다.
sudo find /tmp -type f -printf '%s %p\n' | sort -nr | head -10
  1. 가장 큰 파일을 제거한 다음 다음 명령을 다시 실행하여 /tmp 디렉토리에 충분한 공간이 있는지 확인합니다.
df -h /tmp
  1. 검색 엔진 VM을 재시작합니다. 
  2. PowerProtect Data Manager에서 검색 엔진 상태를 확인하고 작동 중인지 확인합니다.
Article Properties
Article Number: 000214547
Article Type: Solution
Last Modified: 14 Jun 2023
Version:  4
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