NetWorker: "NetWorker Version" in client properties not updating after NetWorker client upgrade

Summary: After upgrading the NetWorker client software on a system, the clients "NetWorker version" is not updated in the client properties.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

After upgrading the NetWorker client software on a system, the clients "NetWorker version" is not updated in the client properties. 

Client Properties

The following commands show what the version of NetWorker is installed on the client:

Linux:

strings /usr/sbin/nsrexecd | grep "@(#) Release"
Windows: 
wmic product where "PackageName = 'NwClientMsi.msi'" get Name, Version
 

The client is not configured in a Protection Group as indicated by the (!) next to the client name:

Unprotected client

Cause

When the NetWorker client software is upgraded, the "NetWorker version" shown in the client will not be updated until the client is backed up. This is as per design.

When the client shows (!) next to the name it means it is not protected in a NetWorker protection group. And no backups of the client are performed.

Example scenario where this might be observed. The client who's version is not correct in the client properties is the physical node of a cluster. The cluster shared data is protected through a client resource created using the logical cluster name. The physical nodes and their local file systems are not being backed up, or are backed up infrequently.

Whether the example scenario is applicable or not, if there has been no backup of the client since the NetWorker client software was updated, the "NetWorker Version" details in the client properties will not be updated to reflect the new client version.

Resolution

NetWorker is functioning as designed. 

Request For Enhancement (RFE) NW-I-2296 has been opened to have the "NetWorker version" details updated without needing to backup the system. If you would like to track this RFE, reach out to your Dell Site Account Manager (SAM) or sales representative with RFE number NW-I-2296.

Affected Products

NetWorker

Products

NetWorker Family, NetWorker Series
Article Properties
Article Number: 000225492
Article Type: Solution
Last Modified: 30 May 2024
Version:  2
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