Avamar: Exchange backups failing with error "The WinRM client cannot process the request"
Summary: This article provides guidance for resolving Exchange backup failures in Avamar caused by PowerShell connectivity issues. These failures typically occur when the Exchange plugin cannot establish a remote PowerShell session with the mailbox server. ...
Symptoms
2024-05-13 17:00:08 avexvss Error <0000>: Error [exchangesvr.avamar.com] Connecting to remote server failed with the following error message : The WinRM client cannot process the request. It cannot determine the content type of the HTTP response from the destination computer. The content type is absent or invalid. For more information, see the about_Remote_Troubleshooting Help topic.
2024-05-13 17:00:08 avexvss Error <16954>: Unable to initialize Powershell interface process -- cannot continue.
2024-05-13 17:00:08 avexvss Error <13077>: Unable to complete backup.
VERBOSE: Connecting to exchangesvr.domain.com
[exchangesvr.domain.com] Connecting to remote server failed with the following error message : The WinRM client cannot process the request. It cannot determine the content type of the HTTP response from the destination computer. The content type is absent or invalid. For more information, see the about_Remote_Troubleshooting Help topic.
+ CategoryInfo : OpenError: (System.Manageme....RemoteRunspace:RemoteRunspace) [], PSRemotingTransportException
+ FullyQualifiedErrorId : PSSessionOpenFailed
VERBOSE: Connecting to exchangesvr.domain.com
VERBOSE: Connected to exchangesvr.domain.com.
Cause
The Exchange Management Shell connects to the Client Access Services (CAS) server and can only run commands from that machine. The Avamar Exchange plugin runs PowerShell commands in the background to enumerate databases and retrieve mailbox server information.
When PowerShell fails to connect to the actual mailbox server, it incorrectly assumes that the CAS server is the mailbox server. This misidentification causes the backup to fail.
Resolution
Remote PowerShell failures can have multiple root causes.
Review the following Microsoft KB articles for potential solutions:
- https://support.microsoft.com/kb/2028305 (External Link)
- https://learn.microsoft.com/en-us/troubleshoot/exchange/administration/winrm-cannot-process-request (External Link)
If the issue persists after applying the guidance from the above articles, use the following workaround:
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Open the
web.configfile located at:-
C:\Program Files\Microsoft\Exchange Server\V14\ClientAccess\PowerShell\
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Search for any references to:
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%ExchangeInstallPath% %ExchangeInstallDir%
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Replace these variables with the absolute path to the Exchange installation directory, for example:
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C:\Program Files\Microsoft\Exchange Server\V14
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This change ensures that PowerShell resolves the correct path during remote session initialization.