Unable to Update the Wyse Management Suite Standard or Private Cloud Certificate

Summary: This article discusses how to resolve issues updating the Wyse Management Suite standard or Wyse Management Suite Private Cloud PKCS #12 certificate.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Affected Products:

  • Wyse Management Suite Private Cloud
  • Wyse Management Suite Standard

An administrator may observe that the self-sign certificate persists in the Wyse Management Suite UI after uploading a third party or domain-generated certificate.

Current certificate

This issue may be due to a misconfigured SSL Certificate. The SSL Certificate must match the private as displayed below.

Certificate Information

Incorrect setup:

Incorrect setup

Cause

A missing private key could be due to:

  • The certificate is not installed on the same server that generated the CSR.
  • The pending request was deleted from the Internet Information Services (IIS) web server.
  • The certificate was installed through the Certificate Important Wizard rather than through IIS.

Resolution

  1. As an account with administrative permissions, sign into the computer that issues the certificate request.
  2. Right-click the Windows start menu and click Run.
  3. In the Run UI, type MMC and then click OK.
    MMC
  4. In the Microsoft Management Console UI, select File and then click Add/Remove Snap-in.
    Add/Remove Snap-in
  5. Select Certificate and then click Add.
    Add Certificate
  6. In the Certificates snap-in UI, select Computer account and then click Next.
    Select Computer account and click Next
  7. Select Local Computer: (the computer this console is running on) and then click Finish.
    Select Local Computer: (the computer this console is running on) and click Finish
  8. In the Add or Remove Snap-ins UI, click OK.
  9. In the Certificates snap-in:
    1. Expand Certificates.
    2. Right-click the Personal folder.
    3. Select All Tasks.
    4. Click Import.
      Import
  10. In the Welcome to the Certificate Import Wizard UI, click Next.
    Welcome to the Certificate Import Wizard
  11. Click Browse.
    Click Browse
  12. Go to a certificate (.cer) issued by the domain authority or third-party vendor and then click Open.
  13. Click Next.
  14. Select Place all certificates in the following store and then Browse to the Personal folder.
    Select Place all certificates in the following store and Click Next
  15. On selection, click Next.
  16. Click Finish to close the Certificate Import Wizard UI.
  17. In the Certificate MMC UI, double-click the certificate that was imported into the Personal folder.
  18. In the Certificate UI, select the Details tab.
  19. Document the Serial Number value.
    Serial Number value
  20. Click OK to close the Certificate UI.
  21. Right-click the Windows start menu and click Run.
  22. In the Run UI, type CMD and then click OK.
    Run CMD
  23. In Command Prompt:
    1. Type:
      ConsoleCopy
      Certutil –repairstore my [SERIALNUMBER]
    2. Press Enter
    3. Close Command Prompt
      Note: [SERIALNUMBER] is the value that is documented in step 19.
  24. In the Certificates snap-in, right-click Certificates, and then select Refresh.
    Click Refresh
  25. Navigate back to the Wyse Management Suite administrative UI and reattempt to upload the certificate.
    Note: If the problem persists, reach out to Dell Technical Support for assistance. For more information, How to Get Support for Wyse Management Suite.

Affected Products

Wyse Management Suite
Article Properties
Article Number: 000192102
Article Type: Solution
Last Modified: 17 Oct 2024
Version:  5
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