PowerStore: Cluster maken mislukt met fout Kan ICM-netwerk niet maken

Summary: Het maken van het cluster mislukt voor PowerStore 1000, 3000, 5000, 7000, 9000 als de mezzaninekaart met 4 poorten niet aanwezig is. Alleen de PowerStore 500T ondersteunt initialisatie zonder de mezzaninekaart met 4 poorten, als blokoptimalisatie. Als de mezzaninekaart niet aanwezig is op de 500T, is initialisatie als unified niet beschikbaar en grijs weergegeven. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Wanneer de mezzaninekaart ontbreekt, kan de initiële configuratiewizard (ICW) zonder fouten worden gestart.
Het mislukt echter later met een generieke foutmelding in de PowerStore Manager UI.

Het servicescript svc_diag lijst --icw_hardware toont geen defecte onderdelen.

Voer de opdracht svc_cluster_diag uit om het probleem te identificeren:
svc_cluster_diag
...
----scanning for current hardware failures--------

Running svc_diag list --icw_hardware from svc_cluster_diag
hw_type Warnado-EX
Running on Node A

Local Node - no Expansion Enclosures detected
Local Node - no Expansion Enclosures detected
Lab Mode Flags: unsupported_drives (False), unsupported_exp_enclosures (False), unsupported_node_hw_configs (False)
Node A FRU Status
        OK | Peer Node        | 0x0f80
        OK | Local Node       | 0x1480
        OK | Embedded Module  | 0x8b81
     Empty | 4-Port Card      | 0x0080     

De status van het knooppunt Fault Status Register geeft aan dat het is gelukt en er worden geen fouten gemeld. De sleuf voor de 4-poorts kaart wordt gerapporteerd als leeg voor zowel knooppunt A als B.

Berichten die het probleem aangeven:
======Scanning for clustering error messages======
Mar 14 11:46:11 xxxx-A control-path[11375]: 2022-03-14 11:46:11.896 [CC] [ERROR] [com.emc.cyclone.contexts.clustering.services.ClusterConfigurationAS|vert.x-eventloop-thread-3] [xxxx|configureTemporaryNetwork_execute] Failed to configure temporary network
                                       General error in networking validation service.

...

Mar 14 11:55:05 xxxx-A control-path[11375]: 2022-03-14 11:55:05.337 [CC] [ERROR] [com.emc.cyclone.contexts.clustering.services.ClusterConfigurationAS|vert.x-eventloop-thread-3]  Clustering internal error, Reason: Platform failure: Node A: Failed to create ICM network
Mar 14 11:55:05 xxxx-A control-path[11375]: 2022-03-14 11:55:05.577 [CC] [ERROR] [com.emc.cyclone.contexts.clustering.services.JoinClusterAS|vert.x-eventloop-thread-3]  Error from Join Cluster: 
                                      Clustering internal error, Reason: Platform failure: Node A: Failed to create ICM network


En:
Mar 14 11:54:57.342515 xxxx-A cyc_config[17710]: A: # Creating ICM network
Mar 14 11:54:58.494138 xxxx-A cyc_config[17710]: A: # ICM VLAN:         '0'
Mar 14 11:54:58.494207 xxxx-A cyc_config[17710]: A: # ICM prefix:       '64'
Mar 14 11:54:58.494247 xxxx-A cyc_config[17710]: A: # ICM appliance IP: 'xxxx:xxxx:xxxx::xxx:xxxx:xxxx:xxxxx'
Mar 14 11:54:58.494277 xxxx-A cyc_config[17710]: A: # ICM node A IP:    'xxxx:xxxx:xxxx::xxx:xxxx:xxxx:xxxxx'
Mar 14 11:54:58.494302 xxxx-A cyc_config[17710]: A: # ICM node B IP:    'xxxx:xxxx:xxxx::xxx:xxxx:xxxx:xxxxx'
Mar 14 11:54:58.495112 xxxx-A cyc_config[17710]: A: Parameters: network_type=NWType.ICM, vlan=0, appliance_ip=xxxx:xxxx:xxxx::xxx:xxxx:xxxx:xxxxx, ip_a=xxxx:xxxx:xxxx::xxx:xxxx:xxxx:xxxxx, ip_b=xxxx:xxxx:xxxx::xxx:xxxx:xxxx:xxxxx, prefix=64, gateway=, debug=False
Mar 14 11:54:58.501819 xxxx-A cyc_config[17710]: A: Base net device was not found to create network (capability = ICM): list index out of range
Mar 14 11:54:58.501994 xxxx-A cyc_config[17710]: A: Could not get base net device: list index out of range
Mar 14 11:54:58.569967 xxxx-A cyc_config[17710]: A: Error: # failed to create ICM network:
Mar 14 11:54:58.586940 xxxx-A cyc_config[17710]: A: Debug: # Task Time: 365 seconds to execute 16_create_base_stack_cluster
Mar 14 11:54:58.586994 xxxx-A cyc_config[17710]: A: Error: # [16/23]: Create Base Stack Cluster -- FAILED
Mar 14 11:54:58.870177 xxxx-A cyc_config[17710]: A: Error: reinit_install: ICM network creation failed:
Mar 14 11:54:58.870243 xxxx-A cyc_config[17710]: A: Error: EC:293
Mar 14 11:54:58.908290 xxxx-A cyc_config[16976]: Error: # Configuration sync: reinit_install failed															 

Cause

Voor de PowerStore 1000, 3000, 5000, 7000 en 9000 T en X is de mezzaninekaart altijd vereist, zelfs als het systeem block-geoptimaliseerd moet worden geïmplementeerd en de Ethernet-poorten niet worden aangesloten.

De PowerStore kan het interne ICM-netwerk niet maken als de mezzaninekaart niet aanwezig is.
De aanwezigheid van de mezzaninekaart controleren:
[SVC:service@xxxx-A user]$ svc_diag list --hardware --sub_options inventory | grep -i mezzanine0 -A 2
FRU Device Description : SLIC1 (ID 14)
 Device not present (Timeout)
Wanneer de mezzaninekaart aanwezig is, is dit de verwachte uitvoer:
[SVC:service@xxxx-A user]$ svc_diag list --hardware --sub_options inventory | grep -i mezzanine0 -A 2
FRU Device Description : Mezzanine0 (ID 27)
 Chassis Type          : Rack Mount Chassis
 Chassis Part Number   :                     

Resolution

Deze PowerStore systemen kunnen niet worden besteld en geïmplementeerd zonder mezzaninekaarten. 

Schakel het PowerStore apparaat uit om de mezzaninekaart terug te zetten en de PowerStore terug te zetten naar de fabrieksinstellingen voor een andere initialisatie: PowerStore: Een PowerStore systeem opnieuw initialiseren naar de fabrieksinstellingen met behulp van de opdracht

svc_factory_resetControleer met de bovenstaande opdracht op beide knooppunten of de mezzaninekaart correct is gedetecteerd voordat het cluster wordt gemaakt.

Affected Products

PowerStore 1000X, PowerStore 1000T, PowerStore 3000X, PowerStore 3000T, PowerStore 5000X, PowerStore 5000T, PowerStore 7000X, PowerStore 7000T, PowerStore 9000X, PowerStore 9000T
Article Properties
Article Number: 000198276
Article Type: Solution
Last Modified: 11 Apr 2022
Version:  1
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.