SourceOne Email Management - Search omits results when searching by dates after converting Indexes from ISYS to ElasticSearch
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Symptoms
You have configured ElasticSearch on an ISYS Archive folder and converted its index sets to ElasticSearch type.
After conversion, searching between certain date ranges in the converted indexes produces no results or items for particular dates are not shown within the results.
No errors are logged in the SourceOne logs or Websearch.
This issue affects only customer that have migrated to ElasticSearch from an ISYS Archive folder.
During migration, ISYS indexes are merged into 1 single ElasticSearch index but fails to update MsgStartDate and MsgEndDate correctly.
The MsgStartDate and MsgEndDate are incorrectly set based on the latest index set merged into the index set whereas it should be set based on the date range of all the messages within the ElasticSearch index set.
If the date search criteria falls out of the MsgStartDate and MsgEndDate, the index is not included in the search thus not providing results from this index.
For example:
The ElasticSearch index for February 2017 has incorrectly set MsgStartDate 20-02-2017 and MsgEndDate 28-02-2017.
If a user searches with a date range of 1st January 2017 and 15th February the results will show only the items found in January as the February index won t be included in the search query.
Cause
This issue is caused by a software defect.
Resolution
This issue is resolved in HotFix Bundles or Service Pack versions on or higher than 7.2.5.5088. (7.2.5 GA).
This issue is resolved in Hotfix Bundles (HFBs) or Service Pack versions on or higher than SourceOne Email Management 7.2.5.6201. (7.2.6 + HFB 3)
Hotfix Bundles and Service Pack kits are available for download via https://www.dell.com/support, Select 'Drivers and Downloads' to access the required software
* Please note Hotfixes are only available for the most current patch or Service Pack versions of the product that were available when this problem was resolved.
** Please note that when installing Hot Fix Bundles (HFBs) they must all be installed in the correct order for ALL fixes to be correctly applied.
*** Please note that it is always recommended to upgrade to the latest version of the SourceOne release, service pack and Hot Fix Bundle to ensure all currently resolved issues will be fixed including the issue as stated above.
This issue is resolved in Hotfix Bundles (HFBs) or Service Pack versions on or higher than SourceOne Email Management 7.2.5.6201. (7.2.6 + HFB 3)
Hotfix Bundles and Service Pack kits are available for download via https://www.dell.com/support, Select 'Drivers and Downloads' to access the required software
* Please note Hotfixes are only available for the most current patch or Service Pack versions of the product that were available when this problem was resolved.
** Please note that when installing Hot Fix Bundles (HFBs) they must all be installed in the correct order for ALL fixes to be correctly applied.
*** Please note that it is always recommended to upgrade to the latest version of the SourceOne release, service pack and Hot Fix Bundle to ensure all currently resolved issues will be fixed including the issue as stated above.
Additional Information
This issue has been fixed so that the MsgStartDate and MsgEndDate in the FTindex table are correctly set based on a query sent directly to the ElasticSearch index during the conversion from ISYS to ElasticSearch.
Changes have been implemented in the Index Validation feature to resolve problems caused by incorrect date ranges within the FTIndex table. Index Validation level 1 checks the FTIndex date ranges against the actual date range of docs within the ElasticSearch index and update the FTIndex date range when necessary to match ElasticSearch.
If Index Validation is already configured in your system, make sure you trigger a manual scan of the indexes. As per documentation, scheduled index scans will skip those index sets that have already been scanned and there are have not been updates since last scan.
Changes have been implemented in the Index Validation feature to resolve problems caused by incorrect date ranges within the FTIndex table. Index Validation level 1 checks the FTIndex date ranges against the actual date range of docs within the ElasticSearch index and update the FTIndex date range when necessary to match ElasticSearch.
If Index Validation is already configured in your system, make sure you trigger a manual scan of the indexes. As per documentation, scheduled index scans will skip those index sets that have already been scanned and there are have not been updates since last scan.
Affected Products
SourceOne Email ManagementProducts
SourceOne, SourceOne Email ManagementArticle Properties
Article Number: 000052131
Article Type: Solution
Last Modified: 26 May 2025
Version: 4
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