NVP vProxy: Incremental VM backups fail with "Failed to open version 1 backup descriptor file" 5004-nfs lookup failed

Summary: Incremental backups fail with the following error observed in the Virtual Machine (VM) backup logs "Err: 5004-nfs lookup failed (nfs: No such file or directory)"

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

The NetWorker VMware Protection (NVP) integration is configured with the vProxy Appliance. The incremental backup of a virtual machine was working successfully and started failing indicating it could not open the backup descriptor file. The vProxy backup session log shows:
YYYY-MM-DDTHH:mm:SST ERROR:  [NW_BUILD] Failed to open version 1 backup descriptor file '/NW_SERVER/MTREE/06/60/LONG_SSID/BackupDescriptor.json': [5004] [22153] [140084586215168] DAY MON ## HH:MM:SS YYYY
YYYY-MM-DDTHH:mm:SST ERROR:  [NW_BUILD] 	ddp_open_file_ext() failed for File: //NW_SERVER/MTREE/06/60/LONG_SSID/BackupDescriptor.json, Err: 5004-nfs lookup failed (nfs: No such file or directory)
YYYY-MM-DDTHH:mm:SST ERROR:  [NW_BUILD] Unable to open previous backup.
YYYY-MM-DDTHH:mm:SST ERROR:  [NW_BUILD] Backup has FAILED.

Cause

The "Err: 5004-nfs lookup failed" Data Domain DD Boost message is a generic error message, which can appear for several reasons. 

In one particular incident the vProxy Incremental backup was not able to open the BackupDescriptor.json file on the Data Domain file system as it was unavailable\corrupt. The BackupDescriptor.json was corrupted when a previous backup failed to complete due to an ESXi host disconnect, preventing proper data writing and cleanup. The incremental backup must use a previous incremental backup's files to append the Change Block Tracking (CBT) information and create a new Synthetic full backup.

Resolution

In this scenario, a new FULL level backup should be performed on the VM.  A FULL level backup creates a new directory and not uses the previous incremental backup data on the Data Domain file system.

Affected Products

NetWorker

Products

NetWorker
Article Properties
Article Number: 000078810
Article Type: Solution
Last Modified: 10 Jun 2025
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.