Dell Data Security Shield Modes

Summary: This article discusses the Dell Data Security (formerly Dell Data Protection) shield modes.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Affected Products:

  • Credant Mobile Guardian
  • Dell Encryption Enterprise
  • Dell Data Protection | Enterprise Edition
  • Dell Encryption External Media
  • Dell Data Protection | External Media Edition
  • Dell Encryption Personal
  • Dell Data Protection | Personal Edition
  • Dell Data Protection | Security Tools
  • Dell Encryption Enterprise for Server
  • Dell Data Protection | Server Edition

Affected Platforms:

  • Windows

Policy-based Dell Data Security (formerly Dell Data Protection) software use a shield mode identifier for product classification.

Cause

Warning:
  • Shield mode is determined at the time of product installation and cannot be modified manually.
  • Shield mode is only used to troubleshoot product type or status.

Resolution

The shield modes for Dell Data Security products are:

ID Mode Product
0 Unknown/ Uninitialized Not Initialized/ Unprovisioned1
1 Enterprise Mode Dell Encryption Enterprise \ Dell Data Protection Enterprise Edition Shield
2 Stand Alone Mode Credant Mobile Guardian
3 Enterprise EME Only Mode Dell Encryption External Media \ Dell Data Protection | External Media Edition
4 Locally Managed Mode Dell Encryption Personal \ Dell Data Protection | Personal Edition
5 Essentials Mode Dell Data Protection | Security Tools2
6 Server Encryption Mode Dell Encryption Enterprise for Server \ Dell Data Protection | Server Encryption
7 Saas Mode Dell Encryption Enterprise Shield

1All Dell Data Protection products remain unprovisioned until activated.
2Essential Mode only occurs on installations of Dell Data Protection | Security Tools.

To locate the Shield Mode:

Warning: Takes you into the Windows Registry:
  1. Right-click the Windows Start Menu and then select Run.

Run
Figure 1: (English Only) Run

  1. In the Run user interface (UI), type regedit and then press OK.

Type regedit
Figure 2: (English Only) Type regedit

  1. Go to HKEY_LOCAL_MACHINE\SOFTWARE\Credant\CMGShield.

CMGShield
Figure 3: (English Only) CMGShield

  1. Locate DWORD key SM.

SM
Figure 4: (English Only) SM

Note: In the example, the SM key is set for 1. This identifies the shield mode enterprise edition.

To contact support, reference Dell Data Security International Support Phone Numbers.
Go to TechDirect to generate a technical support request online.
For additional insights and resources, join the Dell Security Community Forum.

 

Affected Products

Dell Encryption
Article Properties
Article Number: 000132837
Article Type: Solution
Last Modified: 05 Mar 2024
Version:  10
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.