KB 196162: Microsoft Exchange DAG (Database Availability Group) incremental backups cannot be restored using NetWorker Module for Microsoft (NMM) 19.4.x.

Summary: Microsoft Exchange DAG (Database Availability Group) incremental backups cannot be restored using NetWorker Module for Microsoft (NMM) 19.4.x.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

NetWorker Server running version 19.4.x may encounter an issue with restore where Microsoft Exchange DAG backups are taken as incremental backup.
When incremental backup is used, ItemPoint cannot process recovered log files and fails with the error below:

"An error occurred processing the log files, continuing without logs."

Note: Continuing without logs may results in data omission from store due to data contained by missing log files.

Cause

It is observed that when a FS (File System) BBB and NMM (BBB) backup co-exist on the client,  NMM incremental backup has inconsistency  that resulted in recovery failure.

Resolution

Product (Operating System or Operating Environment)
 
NetWorker Server 19.4.x
Action Type
 
Workaround
Action Needed
 
Apply appropriate workaround mentioned in the Resolution Details Section.
Who Can Complete the Action
 
NetWorker Administrator / Customer
Issue Addressed in this OS, OE or Software
 
NA
Resolution Detail Workaround options currently available are:
 
  1. Perform Full backup
  2. Flat file restore or GLR and run ItemPoint and choose to 'Continue without logs' and restore the selected mails.
  3. Use 'Eseutil' to repair the database using '/r' or '/p' option

/r - Soft repair
/p - Hard repair.
Solution Considerations Please work as per the mentioned Workaround.
Article Properties
Article Number: 000196162
Article Type: Solution
Last Modified: 02 Dec 2022
Version:  4
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