PowerEdge: Upgrade and Conversion Options for Windows Server after Making Hardware Changes

Summary: The article is a solution to fixing the issue of the system asking for eh product key after making a hardware change.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

When making a hardware change to the server, and reinstalling the Windows server and comes across an activation error: run 'slui.exe 0x2a 0xC004F069'.

 

Screenshot of the full error:

Windows error

Cause

When a hardware change is made on the server.

 

Resolution

  1. To check what is the edition of the operating system run the following

     

    DISM /online /Get-CurrentEdition

     

  2. Run the following, this applies to the generic volume license key

     

    DISM /online /Set-Edition:<edition ID> /ProductKey:XXXXX-XXXXX-XXXXX-XXXXX-XXXXX /AcceptEula
     
     
    Note: Make sure to use the generic key from: https://learn.microsoft.com/en-us/windows-server/get-started/kms-client-activation-keys This hyperlink is taking you to a website outside of Dell Technologies.

    Ex: DISM /online /Set-Edition:ServerDatacenter /ProductKey:XXXXX-XXXXX-XXXXX-XXXXX-XXXXX /AcceptEula

     

  3. Run the following command slmgr.vbs /ipk XXXXX-XXXXX-XXXXX-XXXXX-XXXXX, at this stage you use your own product key and this replaces the generic key with your own product key, but does not activate the operating system.

  4. To activate your operating system, you must run command slmgr /ato to activate the license

     

 

TIP


If you run in command prompt slmgr, a "windows script host" window appears.
If you press OK at the bottom, it shows you all the slmgr commands/ switches that can be used.

slmgr

 

Affected Products

Microsoft Windows Server 2022

Products

C Series, HS Series, Modular Infrastructure, Rack Servers, Tower Servers, XE Servers, XR Servers, OEM Server Solutions
Article Properties
Article Number: 000201865
Article Type: Solution
Last Modified: 05 Dec 2024
Version:  4
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