Avamar: Cannot browse backup log "Client failed to respond to a request for its log."
Summary: Attempting to browse an Avamar backup log fails with "Client failed to respond to a request for its log."
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Symptoms
When trying to browse a backup job log in the Avamar UI Activity screen, the operation times out.
The "Activity Session Drill-Down" window shows "The session log is unavailable."
The error is "Client failed to respond to a request for its log."
The avagent.log shows the following when the operation is performed and debug enabled:
For more details, see Avamar: How to Gather Log Files for Troubleshooting Avamar Client Backup and Restore Issues
There is no issue with the paging. The client is browsable (Windows File System) in the Backup/Restore screen.
The "Activity Session Drill-Down" window shows "The session log is unavailable."
The error is "Client failed to respond to a request for its log."
The avagent.log shows the following when the operation is performed and debug enabled:
For more details, see Avamar: How to Gather Log Files for Troubleshooting Avamar Client Backup and Restore Issues
2018/05/31-17:12:33.04699 [agent_listenworker:33276:39:] agent_commands::browse_workorder timeout 9 seconds
2018/05/31-17:12:40.01300 [agent_listenworker:33276:39:] filecollector::find_files found 'Tlog_2000_15-SQL2012_2015_AlwaysOn_Tlog-1527725700151-3006-SQL.alg'
2018/05/31-17:12:40.02500 [agent_listenworker:33276:39:] filecollector::find_files found 'Tlog_2000_15-SQL2012_2015_AlwaysOn_Tlog-1527725700151-3006-SQL.log'
2018/05/31-17:12:40.03600 [agent_listenworker:33276:39:] filecollector::find_files found 'Tlog_2000_15-SQL2012_2015_AlwaysOn_Tlog-1527725700151#1-3006-SQL.avtar.log'
2018/05/31-17:12:40.04800 [agent_listenworker:33276:39:] filecollector::find_files found 'Tlog_2000_15-SQL2012_2015_AlwaysOn_Tlog-1527725700151#0-3006-SQL.avtar.log'
2018/05/31-17:12:49.66599 [agent_listenworker:33276:39:] agent_commands::browse_workorder timed out
2018/05/31-17:12:49.66799 [agent_listenworker:33276:39:] agent_message::sendp <browse> server->isclosed:0, ssl:0, listenfirst_flag:1, listenfirst:0
2018/05/31-17:12:49.66899 [agent_listenworker:33276:39:] agent_message::sendp about to send xmlsize:127 filerefsize:125
2018/05/31-17:12:49.67100 [agent_listenworker:33276:39:] agent_message::sendp
There is no issue with the paging. The client is browsable (Windows File System) in the Backup/Restore screen.
Cause
The default browse timeout response time is 10 s. This is not enough to retrieve large logs.
To check the current "Browse Time-out" setting, log in to the Avamar Server as admin, using SSH and run.
For example:
Check the settings:
To check the current "Browse Time-out" setting, log in to the Avamar Server as admin, using SSH and run.
mccli client show --name=<client_path>
For example:
mccli client show --name=/clients/client-1.domain.com
Check the settings:
Browse Timeout 10 seconds
Resolution
- Increase the "Browse Timeout" to 60 s or more.
Restart the "Backup Agent" service on the client.
mccli client edit --name=/clients/client-1.domain.com --timeout=60
Restart the "Backup Agent" service on the client.
Additional Information
To enable debug in the avagent.log:
Create avagent.cmd file in Avamar's VAR folder on the client. The default location is c:\Program Files\avs\var.
- Add --debug to avagent.cmd.
Restart the Back Agent service.
Create avagent.cmd file in Avamar's VAR folder on the client. The default location is c:\Program Files\avs\var.
- Add --debug to avagent.cmd.
Restart the Back Agent service.
Affected Products
AvamarArticle Properties
Article Number: 000202240
Article Type: Solution
Last Modified: 20 Jul 2023
Version: 2
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