Avamar : Impossible de parcourir le log de sauvegarde « Le client n’a pas répondu à une demande de son log. »
Summary: La tentative de navigation dans un log de sauvegarde Avamar échoue avec le message « Client failed to respond to a request for its log ».
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Symptoms
Lorsque vous tentez de parcourir un log de procédure de sauvegarde dans l’écran Activité de l’interface utilisateur Avamar, l’opération expire.
La fenêtre « Activity Session Drill-Down » affiche « The session log is unavailable ».
L’erreur est « Client failed to respond to a request for its log ».
Le fichier avagent.log affiche les informations suivantes lorsque l’opération est exécutée et que le débogage est activé :
Pour plus d’informations, voir Avamar : Collecte des fichiers log pour le dépannage des problèmes de sauvegarde et de restauration du client Avamar
Il n’y a aucun problème avec l’échange. Le client est accessible (système de fichiers Windows) dans l’écran Backup/Restore .
La fenêtre « Activity Session Drill-Down » affiche « The session log is unavailable ».
L’erreur est « Client failed to respond to a request for its log ».
Le fichier avagent.log affiche les informations suivantes lorsque l’opération est exécutée et que le débogage est activé :
Pour plus d’informations, voir Avamar : Collecte des fichiers log pour le dépannage des problèmes de sauvegarde et de restauration du client Avamar
2018/05/31-17:12:33.04699 [agent_listenworker:33276:39:] agent_commands::browse_workorder timeout 9 seconds
2018/05/31-17:12:40.01300 [agent_listenworker:33276:39:] filecollector::find_files found 'Tlog_2000_15-SQL2012_2015_AlwaysOn_Tlog-1527725700151-3006-SQL.alg'
2018/05/31-17:12:40.02500 [agent_listenworker:33276:39:] filecollector::find_files found 'Tlog_2000_15-SQL2012_2015_AlwaysOn_Tlog-1527725700151-3006-SQL.log'
2018/05/31-17:12:40.03600 [agent_listenworker:33276:39:] filecollector::find_files found 'Tlog_2000_15-SQL2012_2015_AlwaysOn_Tlog-1527725700151#1-3006-SQL.avtar.log'
2018/05/31-17:12:40.04800 [agent_listenworker:33276:39:] filecollector::find_files found 'Tlog_2000_15-SQL2012_2015_AlwaysOn_Tlog-1527725700151#0-3006-SQL.avtar.log'
2018/05/31-17:12:49.66599 [agent_listenworker:33276:39:] agent_commands::browse_workorder timed out
2018/05/31-17:12:49.66799 [agent_listenworker:33276:39:] agent_message::sendp server->isclosed:0, ssl:0, listenfirst_flag:1, listenfirst:0
2018/05/31-17:12:49.66899 [agent_listenworker:33276:39:] agent_message::sendp about to send xmlsize:127 filerefsize:125
2018/05/31-17:12:49.67100 [agent_listenworker:33276:39:] agent_message::sendp
Il n’y a aucun problème avec l’échange. Le client est accessible (système de fichiers Windows) dans l’écran Backup/Restore .
Cause
Le temps de réponse par défaut du délai d’expiration de la navigation est de 10 s. Cela ne suffit pas pour récupérer des logs volumineux.
Pour vérifier le paramètre « Browse Time-out » actuel, connectez-vous au serveur Avamar en tant qu’administrateur, à l’aide de SSH et exécutez.
Par exemple :
Vérifiez les paramètres :
Pour vérifier le paramètre « Browse Time-out » actuel, connectez-vous au serveur Avamar en tant qu’administrateur, à l’aide de SSH et exécutez.
mccli client show --name=
Par exemple :
mccli client show --name=/clients/client-1.domain.com
Vérifiez les paramètres :
Browse Timeout 10 seconds
Resolution
- Augmentez le délai d’expiration de la navigation à 60 s ou plus.
Redémarrez le service « Backup Agent » sur le client.
mccli client edit --name=/clients/client-1.domain.com --timeout=60
Redémarrez le service « Backup Agent » sur le client.
Additional Information
Pour activer le débogage dans le fichier avagent.log :
Create avagent.cmd dans le dossier VAR d’Avamar sur le client. L’emplacement par défaut est c :\Program Files\avs\var.
- Ajouter --debug à avagent.cmd.
Redémarrez le service Back Agent.
Create avagent.cmd dans le dossier VAR d’Avamar sur le client. L’emplacement par défaut est c :\Program Files\avs\var.
- Ajouter --debug à avagent.cmd.
Redémarrez le service Back Agent.
Affected Products
AvamarArticle Properties
Article Number: 000202240
Article Type: Solution
Last Modified: 20 Jul 2023
Version: 2
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