PowerStore:无中断升级到 3.0 及更高版本后,WebUI (UI) 不可用,节点重新启动或关闭设备电源后重启

Summary: 无中断升级到 3.0 及更高版本后,无法访问 Web UI 或向系统发出 PowerStore CLI 命令,节点将重新启动或关闭设备的电源后重启。

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

PowerStore Manager UI 或 CLI(RestAPI 和 PSTCLI)不可用,可能会返回以下错误:
  • 在无中断升级、节点重新启动或设备电源关闭后,无法访问 PowerStore Manager UI(用户无法登录):
  • 尝试登录失败,并显示错误:"Service unavailable.Please retry in a few minutes.(0xE04040010004)“或”503 服务不可用”
  • 如果使用服务端口浏览初始配置向导 (ICW),用户可能会看到一条消息,指示“Loading...”。在“Cluster Details”步骤中,该步骤会持续一段时间。最终,UI 可能会显示“The required appliance was not found or Request timed out”。

由于此问题:
  • 对于未配置的设备
    • 无法访问 PowerStore Manager 登录页面或登录 REST API。
    • 由于设备上没有发现 IP,Connection Utility 无法在此类环境中显示已配置和未配置的设备。
  • 对于已配置的设备
    • 无法访问 PowerStore Manager 登录页面或登录 REST API。
    • 无法执行 Add Appliance 操作。

使用 ssh 访问系统,如果未启用 ssh,请使用 PowerStore 中概述的服务端口:使用服务 LAN 端口访问 SSH 和 PowerStore Manager。

无法发出 pstcli 命令。
[SVC:service@XXXXXXX-B user]$ pstcli -d  -u admin -session
Password (for host localhost):
The system was unable establish a secure connection to the storage server.
disc0 上没有绑定 IPv4 169.254/16 IP:
 
[SVC:service@XXXXXXX-A user]$ ip a show | grep disc0 -A 3
11: disc0@eno1:  mtu 1500 qdisc noqueue state UP group default qlen 1000
    link/ether aa:aa:aa:aa:aa:aa brd ff:ff:ff:ff:ff:ff
    inet6 fe80::18df:bcff:fe34:2b4a/64 scope link
       valid_lft forever preferred_lft forever
 
[SVC:service@XXXXXXX-B user]$ ip a show | grep disc0 -A 3
11: disc0@eno1:  mtu 1500 qdisc noqueue state UP group default qlen 1000
    link/ether bb:bb:bb:bb:bb:bb brd ff:ff:ff:ff:ff:ff
    inet6 fe80::18df:bcff:fe34:2b4a/64 scope link
       valid_lft forever preferred_lft forever

 

 

Cause

此问题仅影响 PowerStoreOS 3.0 及更高版本。
  • 在节点启动期间,avahi-autoipd 服务将随机获取 169.254.0.0/16 范围内的 IP,测试是否有任何其他设备使用 arping 使用此 IP,然后将其绑定到 disc0 接口
  • 加载控制路径 HTTP 堆栈需要 disc0 接口 IP 地址。
  • 由于管理网络环境中的网络设备出现意外的 ARP 响应,avahi-autoipd 服务无法获取 IP 地址,这会阻止控制路径 HTTP 堆栈加载,并导致 WebUI 和 PSTCLI 访问丢失。

Resolution

解决办法:
  • 识别向 PowerStore 发送意外 ARP 响应的设备。
  • 可以通过停止在管理网络中充当代理 ARP 的交换机或设备来解决此问题。通过以下任一方式执行此操作:
    • 将交换机固件更新到包含问题修复的版本(与 Cisco 交换机相关 ,如 https://quickview.cloudapps.cisco.com/quickview/bug/CSCul01316 中所述)
    • 如果在 169.254.0.0/16 的 Zeroconf/Avahi IP 范围的交换机上启用了“proxy ARP”,则建议将其禁用或重新配置为排除此范围,因为它不应用于代理 ARP。
      • 咨询客户的网络管理员,以验证禁用此设置不应影响任何其他网络服务。
      • 请咨询客户的网络管理员,了解执行此更改的最佳方式。
    • 将 PowerStore 的管理网络隔离到交换机上的其他访问或本机 VLAN。
  • 完成上述所有操作后,验证 disc0 的 IPv4 地址在 169.254.0.0/16 范围内
[SVC:service@XXXXXXX-A user]$ ip a show | grep disc0 -A 3
11: disc0@eno1:  mtu 1500 qdisc noqueue state UP group default qlen 1000
    link/ether ea:44:78:0a:05:c0 brd ff:ff:ff:ff:ff:ff
    inet 169.254.60.18/16 brd 169.254.255.255 scope link disc0:mc
       valid_lft forever preferred_lft forever


[SVC:service@XXXXXXX-B user]$ ip a show | grep disc0 -A 3
11: disc0@eno1:  mtu 1500 qdisc noqueue state UP group default qlen 1000
    link/ether 1a:df:bc:34:2b:4a brd ff:ff:ff:ff:ff:ff
    inet 169.254.64.234/16 brd 169.254.255.255 scope link disc0:mc
       valid_lft forever preferred_lft forever

 

 
     
    • 重新启动控制路径 
    [SVC:service@XXXXXXX-B user]$ svc_container_mgmt restart CP
    Waiting for container restart
    Container controlpath restart returned: 0
    Container controlpath is back up
    Waiting for stack to load
    Waiting for stack to load
    Waiting for stack to load
    Waiting for stack to load
    [SVC:service@XXXXXXX-B user]$
    

    如果无法识别发送意外 ARP 响应的网络设备,或者需要对此问题提供任何帮助,请联系技术支持或您的授权服务代表,并引用此戴尔知识库文章 ID。

    修复:
    此问题已在 PowerStoreOS v3.6.0.0
    中得到修复(请参阅此操作系统版本的发行说明中列出的 MDT-498676。)

    Affected Products

    PowerStore, PowerStore 1000X, PowerStore 1000T, PowerStore 1200T, PowerStore 3000X, PowerStore 3000T, PowerStore 3200T, PowerStore 5000X, PowerStore 5000T, PowerStore 500T

    Products

    PowerStore 5200T, PowerStore 7000X, PowerStore 7000T, PowerStore 9000X, PowerStore 9000T, PowerStore 9200T
    Article Properties
    Article Number: 000211171
    Article Type: Solution
    Last Modified: 23 Oct 2023
    Version:  7
    Find answers to your questions from other Dell users
    Support Services
    Check if your device is covered by Support Services.