NVP vProxy: VM FLR o Instant Access Restore ha esito negativo con errore "Unable to create datastore... Impossibile completare l'operazione Sysinfo in corso... Unable to query remote mount point"

Summary: VM File Level Restore (FLR) o Instant Access Restore (IA) eseguito tramite l'appliance vProxy NetWorker VMware Protection (NVP) ha esito negativo con errore "Operation failed, diagnostics report: Montaggio non riuscito: Impossibile completare l'operazione Sysinfo. Per ulteriori dettagli, consultare il file di registro VMkernel: Unable to query remote mount point's attributes" quando NFSv4 è la versione di esportazione predefinita definita nel sistema operativo DD. ...

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Symptoms

Le VM VMware sono protette con l'appliance vProxy NetWorker VMware Protection (NVP).

Il processo di ripristino dell'immagine della VM ha esito positivo; tuttavia il restore a livello di file (FLR) o l'accesso istantaneo (IA) non riesce.

Il ripristino restituisce il seguente errore:
  • I log FLR si trovano in vProxy in:
    • /opt/emc/vproxy/runtime/logs/recycle/vflrd
  • Se la sessione di ripristino è stata salvata da NMC, i registri si trovano sul server NetWorker in:
    • Linux: /nsr/logs/recover/
    • Windows: C:\Programmi\EMC NetWorker\nsr\logs\recover\
159373:nsrvproxy_flr: vProxy Log: 2023-04-24T18:12:26Z ERROR: [@(#) Build number: 40] Unable to create datastore 'EMC-FLR-vproxy01.amer.lan-1677772117' using 'ddve.amer.lan:/data/col1/linux1/FLR-vproxy01.amer.lan-9f448bb5-e45f-4467-9696-993a7790be69': ServerFaultCode: An error occurred during host configuration. Operation failed, diagnostics report: Mount failed: Unable to complete Sysinfo operation. Please see the VMkernel log file for more details.: Unable to query remote mount point's attributes 152793:nsrvproxy_flr: vProxy Log Ends ================================================= 150017:nsrvproxy_flr: Saveset Mount was terminated...

In Data Domain NFSv4 è abilitato:
 
Data Domain System Manager mostra NFSv4 abilitato
Figura 1. Data Domain System Manager mostra NFSv4 abilitato

La versione predefinita di Data Domain per l'esportazione è "4":
  • Comando DD: 
sysadmin@ddve# nfs option show default-export-version 

Option                   Value 
----------------------   ----- 
default-export-version   4 
----------------------   -----

Cause

NFSv3 è l'impostazione predefinita richiesta per VM FLR e restore IA in base alla NetWorker VMware Integration Guide.

Resolution

  1. Assicurarsi che NFSv3 sia abilitato sul sistema Data Domain:
    1. Accedere all'interfaccia utente web di DDEM: https:// DD-ADDRESS/ddem
    2. Passare a Protocolli > NFS
    3. Cliccare su Abilita se NFSv3 viene visualizzato come "currently not active".
Modificare NFSv3 in Enabled in Data Domain System Manager
Figura 2. Modificare NFSv3 in Enabled in Data Domain System Manager. 
 
In alternativa

, abilitare NFSv3 dalla riga di comando DD con il comando:
nfs enable version 3
  1. Assicurarsi che NFSv3 sia impostato come default-export-version:
    1. Accedere alla riga di comando di Data Domain come sysadmin.
    2. Verificare che default-export-version sia impostata su "3" con il comando:
nfs option show default-export-version
  1. Se NFSv3 è impostato su "4", modificarlo in "3"
nfs option set default-export-version 3

Esempio:

sysadmin@ddve# nfs option set default-export-version 3 
NFS option 'default-export-version' set to '3'. 
sysadmin@ddve# nfs option show default-export-version 
Option                   Value 
----------------------   ----- 
default-export-version   3 
----------------------   -----
  1. Eseguire il ripristino della VM.

Additional Information

La NetWorker VMware Integration Guide è disponibile sul supporto Dell all'indirizzo
 https://www.dell.com/support/home/product-support/product/networker/docs

Affected Products

NetWorker

Products

NetWorker Family, NetWorker Series
Article Properties
Article Number: 000212719
Article Type: Solution
Last Modified: 26 Mar 2025
Version:  3
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