Precisions Do Not Charge with Single Connector Docks
Summary: When a Precision 7000 series laptop is connected to a dock using a single USB Type-C cable, it does not charge correctly.
Symptoms
A Precision 7000 series laptop does not charge, charges intermittently, or it does not detect that the charger has been connected. This only happens when a dock is connected to the computer with a single USB Type-C cable. Other unpredictable symptoms may occur because this is an unsupported configuration. The WD19DC and WD19DCS dual connector docks were designed to support the higher power requirements of these Precision computers.
Affected Platforms:
- Precision 7560
- Precision 7670
- Precision 7680
- Precision 7760
- Precision 7770
- Precision 7780
Affected Docks:
- Dell Dock WD19
- Dell Dock - WD19S
- Dell Thunderbolt Dock - WD19TB
- Dell Thunderbolt Dock - WD19TBS
- Dell Thunderbolt Dock - WD22TB4
Cause
These are high-performance computers that require more power than a single USB Type-C connection to a dock supports.
Resolution
For the best experience, Dell Technologies recommends using a WD19DC or WD19DCS dock with these Precision laptops.
Workaround:
It is possible to use one of the affected docks listed above, but you must also plug in the laptop’s AC adapter.
- Disconnect the dock from the laptop.
- Locate the AC adapter that came with the laptop.
- Plug this AC adapter directly into the laptop.
- Plug the dock into the laptop.
- Confirm that it is charging correctly.