Latitude 3330 Disconnects from Dell P2223HC, P2422HE, or P2722HE Monitors When Using USB-C

Summary: This article provides information about a disconnection issue between Dell monitor P2223HC, P2422HE, or P2722HE and a Latitude 3330 directly using USB-C.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

When either the P2223HC, P2422HE, or P2722HE Dell monitors are connected to a Latitude 3330 directly using USB-C, the monitors may appear to intermittently flicker, blank, disconnect, or going black. This causes the laptop screen to also go black while the monitors are reconnecting to the laptop after the initial disconnect. It may also be observed that when viewing the Windows Display Settings, the external monitors disappear during the issue.

The issue is not seen when connected using a docking station.

Affected Platforms:

  • Latitude 3330

Affected Monitors:

  • Dell P2223HC
  • Dell P2422HE
  • Dell P2722HE

Cause

No cause information is available.

Resolution

Updating to BIOS version 1.19.0 or later on the computer resolves the issue. To download and install the BIOS, reference BIOS Update Guide.

Affected Products

Dell P2422HE, Dell P2722HE, Latitude 3330, Dell P2223HC
Article Properties
Article Number: 000221465
Article Type: Solution
Last Modified: 13 Nov 2025
Version:  6
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.