Skip to main content
  • Place orders quickly and easily
  • View orders and track your shipping status
  • Create and access a list of your products
  • Manage your Dell EMC sites, products, and product-level contacts using Company Administration.

Dell EMC Configuration Guide for the S4048T–ON System 9.14.2.4

PDF

Redistributing iBGP Routes into IGP

Dell EMC Networking OS supports redistributing iBGP routes into an Internal Gateway Protocol (IGP), such as, OSPF and IS-IS.

NOTE When you enable redistribution of iBGP routes into an IGP, ensure that you use route maps to control what prefixes are redistributed. Redistributing all iBGP routes can create a loop in the network. After configuring the bgp redistribute-internal command, use the clear ip BGP * command to clear all BGP sessions.
Redistribute iBGP routes.
ROUTER BGP, ROUTER BGP-address-family, ROUTER BGP-address-family-IPv6, IPv4 VRF mode, and IPv6 Unicast VRF mode
bgp redistribute-internal

The following is an example configuration of redistributing iBGP routes into OSPF with the default VRF:

!
router ospf 100
 router-id 1.1.1.1
 network 10.10.10.0/24 area 0
 redistribute bgp 65535 route-map bgp2ospf4 
!
ipv6 router ospf 1
 router-id 1.1.1.1
 redistribute bgp 65535 route-map bgp2ospf6 
!
router bgp 65535
 maximum-paths ibgp 8
 bgp redistribute-internal  
 neighbor 20.20.20.2 remote-as 65535 
 neighbor 20.20.20.2 no shutdown 
 neighbor 20.20.20.3 remote-as 65535 
 neighbor 20.20.20.3 no shutdown 
 neighbor 20::2 remote-as 65535 
 neighbor 20::2 no shutdown 
 neighbor 20::3 remote-as 65535 
 neighbor 20::3 no shutdown 
 !
 address-family ipv6 unicast
  bgp redistribute-internal  
 
  neighbor 20::2 activate
  neighbor 20::3 activate
  exit-address-family
! 

interface Vlan 10
 ip address 10.10.10.1/24
 ipv6 address 10::1/64
 ipv6 ospf 1 area 0
 tagged Port-channel 10
 ip ospf priority 255
 no shutdown 

The following is an example configuration of redistributing iBGP routes into OSPF with a non-default VRF:

interface Vlan 11
 ip vrf forwarding core1
 ip address 11.11.11.1/24
 ipv6 address 11::1/64
 ipv6 ospf 11 area 0
 tagged Port-channel 10
 ip ospf priority 255
!  
router ospf 11 vrf core1
 router-id 11.11.11.1
 network 11.11.11.0/24 area 0
 redistribute bgp 65535 route-map bgp2ospf4
! 
ipv6 router ospf 11 vrf core1
 redistribute bgp 65535 route-map bgp2ospf6

router bgp 65535
address-family ipv4 vrf core1
bgp redistribute-internal  
neighbor 21.21.21.2 remote-as 65535 
 neighbor 21.21.21.2 no shutdown 

address-family ipv6 unicast vrf core1
bgp redistribute-internal  
neighbor 21::2 activate
neighbor 21::3 activate
exit-address-family

The following is an example configuration of redistributing iBGP routes into IS-IS with the default VRF:

router isis 100
 advertise level2-into-level1 isis_static
 is-type level-1
 net 49.1000.6000.6006.00
 redistribute static level-1 
 redistribute connected 
MAA-S3048-6592#

router isis 100
 metric-style wide level-1
 metric-style wide level-2
 net 49.1000.6000.6006.00
 redistribute bgp 65535 route-map bgp2ospf4 
 !
 address-family ipv6 unicast
 redistribute bgp 65535 route-map bgp2ospf6 
 exit-address-family
!
router isis vrf core1
 metric-style wide level-1
 metric-style wide level-2
 net 11.1000.6000.6006.00
 redistribute bgp 65535 
 !
 address-family ipv6 unicast
 redistribute bgp 65535 
 exit-address-family
! 
interface Vlan 10
 ip address 10.10.10.2/24
 ipv6 address 10::2/64
 tagged Port-channel 10
 ip router isis 100
 ipv6 router isis 100
 vrrp bfd all-neighbors
! 
 vrrp-group 1 
  virtual-address 10.10.10.100 
! 
 vrrp-ipv6-group 1 
  virtual-address 10::100 
  virtual-address fe80::10 
 no shutdown
!
interface Vlan 11
 ip vrf forwarding core1
 ip address 11.11.11.2/24
 ipv6 address 11::2/64
 tagged Port-channel 10
 ip router isis
 ipv6 router isis
! 
 vrrp-group 1 
  virtual-address 11.11.11.100 
! 
 vrrp-ipv6-group 1 
  virtual-address 11::100 
  virtual-address fe80::11 
 no shutdown
! 

If you unconfigure the bgp redistribute-internal command, use the clear ip BGP * command to clear all BGP sessions.


Rate this content

Accurate
Useful
Easy to understand
Was this article helpful?
0/3000 characters
  Please provide ratings (1-5 stars).
  Please provide ratings (1-5 stars).
  Please provide ratings (1-5 stars).
  Please select whether the article was helpful or not.
  Comments cannot contain these special characters: <>()\