Touchpad Light Fails to Illuminate with Closed Laptop Lid

Summary: Is your touchpad icon unresponsive after closing your laptop lid? Uncover troubleshooting tips to swiftly regain control of your touchpad functions.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Affected Products:

  • Dell Pro Premium Collaboration Keyboard KB900

When laptops are connected to a monitor and the setting, When I close the lid, in Power Options is set to Do nothing.

Define power buttons and turn on password protection
Figure 1: (English Only) Define power buttons and turn on password protection

  • Join a Zoom call, and Collaboration Touchpad function is available.
  • Close the lid and icons of the Collaboration Touchpad disappear and the Collaboration Touchpad does not function.

KB900 Collaboration Touchpad icons
Figure 2: Dell Pro Premium Collaboration Keyboard KB900 Touchpad icons

Cause

Due to the webcam detecting, the closed lid and performs some functions so that the stream does not stop when the computer goes into a suspended state due to lid close. Collaboration Touchpad is using this same mechanism to detect computers suspend state so that it could turn OFF the touchpad in this case.

Resolution

Update to Dell Peripheral Manager v1.7.2 or later and update keyboard firmware to 1.0.5.8 or later.

KB900 Collaboration Keyboard Update available
Figure 3: (English Only) Dell Pro Premium Collaboration Keyboard KB900 Update available

Affected Products

Dell Pro Premium Collaboration Keyboard KB900
Article Properties
Article Number: 000222575
Article Type: Solution
Last Modified: 22 Apr 2025
Version:  5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.